aboutsummaryrefslogtreecommitdiff
path: root/security/caesarcipher
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-25 08:53:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-25 08:53:06 +0000
commite9e0d32a7c34f41723d9f8940f1028154f5cc7d9 (patch)
tree9de713a33ed3dfb220ae87564400eff2a17dc70e /security/caesarcipher
parentb3ad0f7a2578b571ee0089fe934edef5c6fe48e9 (diff)
downloadports-e9e0d32a7c34f41723d9f8940f1028154f5cc7d9.tar.gz
ports-e9e0d32a7c34f41723d9f8940f1028154f5cc7d9.zip
New port: security/caesarcipher
caesarcipher is an implementation of the traditional Caesar cipher encryption algorithm with an extension to all printable ASCII characters. It can be run as an interactive tool on the command line or process input- and outputfiles that are passed to the ultility. WWW: http://www.olivermahmoudi.com/programming/caesarcipher PR: 222760 Submitted by: Oliver Mahmoudi <fbsd@olivermahmoudi.com>
Notes
Notes: svn path=/head/; revision=491137
Diffstat (limited to 'security/caesarcipher')
-rw-r--r--security/caesarcipher/Makefile24
-rw-r--r--security/caesarcipher/distinfo3
-rw-r--r--security/caesarcipher/pkg-descr7
3 files changed, 34 insertions, 0 deletions
diff --git a/security/caesarcipher/Makefile b/security/caesarcipher/Makefile
new file mode 100644
index 000000000000..58109aaeca34
--- /dev/null
+++ b/security/caesarcipher/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= caesarcipher
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://www.olivermahmoudi.com/files/
+
+MAINTAINER= fbsd@olivermahmoudi.com
+COMMENT= Caesar cipher cryptography tool
+
+LICENSE= BSD2CLAUSE
+
+PLIST_FILES= bin/caesarcipher \
+ man/man1/caesarcipher.1.gz
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-build:
+ cd ${WRKSRC} && ${CC} ${CFLAGS} ${LDFLAGS} -o ${PORTNAME} ${PORTNAME}.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/security/caesarcipher/distinfo b/security/caesarcipher/distinfo
new file mode 100644
index 000000000000..a4979f2dd410
--- /dev/null
+++ b/security/caesarcipher/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507049180
+SHA256 (caesarcipher-1.0.tar.gz) = 278069c80162231b7c5664c27524275bed3d0ef982a8f9b937296a405822bf14
+SIZE (caesarcipher-1.0.tar.gz) = 6096
diff --git a/security/caesarcipher/pkg-descr b/security/caesarcipher/pkg-descr
new file mode 100644
index 000000000000..bc662653a5fc
--- /dev/null
+++ b/security/caesarcipher/pkg-descr
@@ -0,0 +1,7 @@
+caesarcipher is an implementation of the traditional Caesar cipher
+encryption algorithm with an extension to all printable ASCII
+characters. It can be run as an interactive tool on the command
+line or process input- and outputfiles that are passed to the
+ultility.
+
+WWW: http://www.olivermahmoudi.com/programming/caesarcipher