aboutsummaryrefslogtreecommitdiff
path: root/security/clamav-devel/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-20 03:41:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-20 03:41:52 +0000
commitee4e1d457587d32fc4cbe38305e1f8033abcaaf9 (patch)
tree6e165ba11990cb7901b6baa129419f4afc017b12 /security/clamav-devel/Makefile
parentc466d91815df7e377929fdf6a853f82768690b1f (diff)
downloadports-ee4e1d457587d32fc4cbe38305e1f8033abcaaf9.tar.gz
ports-ee4e1d457587d32fc4cbe38305e1f8033abcaaf9.zip
new port: security/clamav
Clam Antivirus is command line virus scanner using database from OpenAntiVirus. PR: ports/40602 Submitted by: TERAMOTO Masahiro <markun@onohara.to>
Notes
Notes: svn path=/head/; revision=73590
Diffstat (limited to 'security/clamav-devel/Makefile')
-rw-r--r--security/clamav-devel/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
new file mode 100644
index 000000000000..0a49f0bd7458
--- /dev/null
+++ b/security/clamav-devel/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: clamav
+# Date created: 15 July 2002
+# Whom: markun@onohara.to
+#
+# $FreeBSD$
+#
+
+PORTNAME= clamav
+PORTVERSION= 0.20
+CATEGORIES= security
+MASTER_SITES= http://clamav.elektrapro.com/stable/
+
+MAINTAINER= markun@onohara.to
+
+RUN_DEPENDS= lha:${PORTSDIR}/archivers/lha \
+ unarj:${PORTSDIR}/archivers/unarj \
+ unrar:${PORTSDIR}/archivers/unrar \
+ zoo:${PORTSDIR}/archivers/zoo \
+ arc:${PORTSDIR}/archivers/arc \
+ unzip:${PORTSDIR}/archivers/unzip
+
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+
+CONFIGURE_ARGS= --prefix=${PREFIX} --disable-clamav --disable-pthreads
+
+MAN1= clamscan.1 freshclam.1 sigtool.1
+
+pre-install:
+ @${ECHO} "==> Creating custom user to run clamav..."
+ ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
+.include <bsd.port.mk>