aboutsummaryrefslogtreecommitdiff
path: root/security/clamav-unofficial-sigs
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-12-15 06:33:34 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-12-15 06:33:34 +0000
commit7061e4a96e7ddc40f6d737a4ed005a685cc2e8b2 (patch)
tree6d5230b35321b18408619bb5c08c03bd4a9a8e79 /security/clamav-unofficial-sigs
parent32b2a18e8549cc7131d6652a5e9c7ae624a4b017 (diff)
downloadports-7061e4a96e7ddc40f6d737a4ed005a685cc2e8b2.tar.gz
ports-7061e4a96e7ddc40f6d737a4ed005a685cc2e8b2.zip
security/clamav-unofficial-sigs: fix regexp problems
PR: 214573 Submitted by: Marko Njezic <sf@maxempire.com> (maintainer) Reported by: freebsdbug@patpro.net
Notes
Notes: svn path=/head/; revision=428603
Diffstat (limited to 'security/clamav-unofficial-sigs')
-rw-r--r--security/clamav-unofficial-sigs/Makefile1
-rw-r--r--security/clamav-unofficial-sigs/files/patch-clamav-unofficial-sigs.sh6
2 files changed, 4 insertions, 3 deletions
diff --git a/security/clamav-unofficial-sigs/Makefile b/security/clamav-unofficial-sigs/Makefile
index a91abebbfe71..38f823ab00a3 100644
--- a/security/clamav-unofficial-sigs/Makefile
+++ b/security/clamav-unofficial-sigs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= clamav-unofficial-sigs
PORTVERSION= 5.3.2
+PORTREVISION= 1
CATEGORIES= security
MAINTAINER= sf@maxempire.com
diff --git a/security/clamav-unofficial-sigs/files/patch-clamav-unofficial-sigs.sh b/security/clamav-unofficial-sigs/files/patch-clamav-unofficial-sigs.sh
index fe91153f8022..abe3f400fe43 100644
--- a/security/clamav-unofficial-sigs/files/patch-clamav-unofficial-sigs.sh
+++ b/security/clamav-unofficial-sigs/files/patch-clamav-unofficial-sigs.sh
@@ -1,4 +1,4 @@
---- clamav-unofficial-sigs.sh.orig 2016-06-03 09:51:21 UTC
+--- clamav-unofficial-sigs.sh.orig 2016-11-18 10:05:40 UTC
+++ clamav-unofficial-sigs.sh
@@ -753,6 +753,8 @@ function make_signature_database_from_as
#Remove the clamav-unofficial-sigs script
@@ -27,7 +27,7 @@
- if [ "$(xshok_array_count "$sanesecurity_mirror_ips")" -lt 1 ] ; then
- sanesecurity_mirror_ips=$(host -t A "$sanesecurity_url" | sed -n '/has address/{s/.*address \([^ ]*\).*/\1/;p;}')
- fi
-+ sanesecurity_mirror_ips=$(host "$sanesecurity_url" | sed 's/.*\s//')
++ sanesecurity_mirror_ips=$(host "$sanesecurity_url" | sed 's/.*[[:space:]]//')
if [ "$(xshok_array_count "$sanesecurity_mirror_ips")" -ge "1" ] ; then
for sanesecurity_mirror_ip in $sanesecurity_mirror_ips ; do
@@ -37,7 +37,7 @@
- if [ "$sanesecurity_mirror_name" == "" ] ; then
- sanesecurity_mirror_name=$(host "$sanesecurity_mirror_ip" | sed -n '/name pointer/{s/.*pointer \([^ ]*\).*\.$/\1/;p;}')
- fi
-+ sanesecurity_mirror_name=$(host "$sanesecurity_mirror_ip" | sed 's/.*\s//' | sed 's/\.$//')
++ sanesecurity_mirror_name=$(host "$sanesecurity_mirror_ip" | sed 's/.*[[:space:]]//' | sed 's/\.$//')
sanesecurity_mirror_site_info="$sanesecurity_mirror_name $sanesecurity_mirror_ip"
xshok_pretty_echo_and_log "Sanesecurity mirror site used: $sanesecurity_mirror_site_info"
$rsync_bin $rsync_output_level $no_motd --files-from="$sanesecurity_include_dbs" -ctuz $connect_timeout --timeout="$rsync_max_time" "rsync://$sanesecurity_mirror_ip/sanesecurity" "$work_dir_sanesecurity" 2>/dev/null