aboutsummaryrefslogtreecommitdiff
path: root/security/clamav
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-01-24 17:04:37 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-01-24 17:04:37 +0000
commitfe390b5b523e70bc5ff1928a67a1f518eba70a84 (patch)
treec66a369ba3fb7b2fa32439379a0c9dcdccae052f /security/clamav
parent3f86bbc0e362aac3c4d26e4fc0bec0d526188e5b (diff)
downloadports-fe390b5b523e70bc5ff1928a67a1f518eba70a84.tar.gz
ports-fe390b5b523e70bc5ff1928a67a1f518eba70a84.zip
- Add an OPTION ICONV to fix a problem that can be caused by auto detection.
No PORTREVISION bump necessary since it's off by default.
Notes
Notes: svn path=/head/; revision=206139
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 92632fe41c9e..447bd08cfe29 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -22,6 +22,7 @@ OPTIONS= ARC "Enable arch archives support" On \
UNRAR "Enable rar archives support" On \
MILTER "Compile the milter interface" Off \
LDAP "libmilter was built with LDAP" Off \
+ ICONV "Enable ICONV support" Off \
STDERR "Print logs to stderr instead of stdout" Off \
EXPERIMENTAL "Build experimental code" Off
@@ -126,6 +127,12 @@ PLIST_SUB+= UNRAR=""
PLIST_SUB+= UNRAR="@comment "
CONFIGURE_ARGS+= --disable-unrar
.endif
+.if defined(WITH_ICONV)
+CONFIGURE_ARGS+=--with-iconv
+USE_ICONV= yes
+.else
+CONFIGURE_ARGS+=--without-iconv
+.endif
.if defined(WITH_MILTER)
USE_RC_SUBR+= clamav-milter