aboutsummaryrefslogtreecommitdiff
path: root/security/cryptlib
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-01 17:25:26 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-12-01 17:25:26 +0000
commitc547e9e899e0cab7bd2c50cbb100e2f041a2ea4d (patch)
treef3beea2e92ac4d20f8d67697dc0fbc4e4bfd93fb /security/cryptlib
parentb05652e4adc416ebf6ca4b0d38199373376ca123 (diff)
downloadports-c547e9e899e0cab7bd2c50cbb100e2f041a2ea4d.tar.gz
ports-c547e9e899e0cab7bd2c50cbb100e2f041a2ea4d.zip
security/cryptlib: fix build on powerpc64le
Diffstat (limited to 'security/cryptlib')
-rw-r--r--security/cryptlib/Makefile2
-rw-r--r--security/cryptlib/files/patch-crypt_osconfig.h2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index 28484e46c006..bdd0dcc64276 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -9,7 +9,7 @@ DISTNAME= cl${PORTVERSION:S/.//g}
MAINTAINER= ale@FreeBSD.org
COMMENT= Powerful security programming toolkit
-ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc powerpc64
+ONLY_FOR_ARCHS= amd64 armv6 armv7 i386 powerpc powerpc64 powerpc64le
OPTIONS_DEFINE= DOCS
diff --git a/security/cryptlib/files/patch-crypt_osconfig.h b/security/cryptlib/files/patch-crypt_osconfig.h
index 4737b39c8c61..3cc1a7d7de9b 100644
--- a/security/cryptlib/files/patch-crypt_osconfig.h
+++ b/security/cryptlib/files/patch-crypt_osconfig.h
@@ -4,10 +4,10 @@
#define L_ENDIAN
#else
#define B_ENDIAN
+ #endif /* Usually big-endian but may be little-endian */
+ #ifdef __LP64__
+ #undef SIXTY_FOUR_BIT
+ #define SIXTY_FOUR_BIT_LONG
+ #endif
- #endif /* Usually big-endian but may be little-endian */
#define BN_LLONG
#define DES_RISC1