aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-30 13:05:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-30 13:05:17 +0000
commit2c01ccf175bbae5b456016e77f5f0ca263934bfc (patch)
treef3a4d5b353df3c5504cff42c97ea6217c8e55aa5 /security/cryptopp
parent8248f236b6528da5635f2c5da19d4440c1910675 (diff)
downloadports-2c01ccf175bbae5b456016e77f5f0ca263934bfc.tar.gz
ports-2c01ccf175bbae5b456016e77f5f0ca263934bfc.zip
- Make static library relocatable
Approved by: Xin LI <delphij@frontfree.net> (maintainer)
Notes
Notes: svn path=/head/; revision=127699
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile2
-rw-r--r--security/cryptopp/files/patch-aa21
2 files changed, 16 insertions, 7 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index edc49bce554b..3f14733f21e5 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cryptopp
PORTVERSION= 5.2.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.eskimo.com/~weidai/ \
@@ -24,6 +25,7 @@ USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
MAKEFILE= GNUmakefile
+CXXFLAGS+= -fPIC
.include <bsd.port.pre.mk>
diff --git a/security/cryptopp/files/patch-aa b/security/cryptopp/files/patch-aa
index bd88a3a0af22..a50c365e4296 100644
--- a/security/cryptopp/files/patch-aa
+++ b/security/cryptopp/files/patch-aa
@@ -1,15 +1,22 @@
---- GNUmakefile.orig Wed Mar 26 17:21:24 2003
-+++ GNUmakefile Wed Mar 26 17:22:16 2003
-@@ -47,7 +47,7 @@
- TESTOBJS = bench.o test.o validat1.o validat2.o validat3.o adhoc.o datatest.o regtest.o
- LIBOBJS = $(filter-out $(TESTOBJS),$(OBJS))
+--- GNUmakefile.orig Sun Jun 20 11:22:24 2004
++++ GNUmakefile Sun Jan 30 02:09:00 2005
+@@ -1,5 +1,5 @@
+ # can't use -fno-rtti yet because it causes problems with exception handling in GCC 2.95.2
+-CXXFLAGS = -g
++CXXFLAGS ?= -g
+ # Uncomment the following two lines to do a release build.
+ # Note that you must define NDEBUG for your own application if you define it for Crypto++.
+ # Make sure you run the validation tests and test your own program thoroughly
+@@ -75,7 +75,7 @@
+ TESTIMPORTOBJS = $(TESTOBJS:.o=.import.o)
+ DLLTESTOBJS = dlltest.dllonly.o
-all: cryptest.exe
+all: cryptest
clean:
- $(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS)
-@@ -56,7 +56,7 @@
+ $(RM) cryptest.exe libcryptopp.a $(LIBOBJS) $(TESTOBJS) cryptopp.dll libcryptopp.dll.a libcryptopp.import.a cryptest.import.exe dlltest.exe $(DLLOBJS) $(LIBIMPORTOBJS) $(TESTIMPORTOBJS) $(DLLTESTOBJS)
+@@ -84,7 +84,7 @@
$(AR) $(ARFLAGS) $@ $(LIBOBJS)
$(RANLIB) $@