aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-12-23 09:42:36 +0000
committerClement Laforet <clement@FreeBSD.org>2004-12-23 09:42:36 +0000
commit30dbf40c5c4176e70cc0118fe07dd9bc705e12b6 (patch)
treeb972ff4b422dfa1dfbf6f03f0f5940b8e9deb5d2 /security/cryptopp
parentc87f780e3e1b2e12de30dc9653f4a5a48d0e6143 (diff)
downloadports-30dbf40c5c4176e70cc0118fe07dd9bc705e12b6.tar.gz
ports-30dbf40c5c4176e70cc0118fe07dd9bc705e12b6.zip
- Update to 5.2.1
PR: 75392 Submitted by: delphij
Notes
Notes: svn path=/head/; revision=124941
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile6
-rw-r--r--security/cryptopp/distinfo4
-rw-r--r--security/cryptopp/files/patch-ab20
-rw-r--r--security/cryptopp/pkg-plist6
4 files changed, 8 insertions, 28 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 254b488701b0..e508ba76d00a 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= cryptopp
-PORTVERSION= 5.2
+PORTVERSION= 5.2.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.eskimo.com/~weidai/ \
http://gd.tuwien.ac.at/privacy/crypto/libs/cryptlib/ \
http://www.mirrors.wiretapped.net/security/cryptography/libraries/cryptolib/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= crypto${PORTVERSION:S/.//g}
+DISTNAME= cryptopp${PORTVERSION:S/.//g}
EXTRACT_SUFX= .zip
-MAINTAINER= delphij@FreeBSD.org.cn
+MAINTAINER= delphij@FreeBSD.org
COMMENT= A free C++ class library of Cryptographic Primitives
NO_WRKSUBDIR= yes
diff --git a/security/cryptopp/distinfo b/security/cryptopp/distinfo
index eec7bb90f224..858dcfe8a823 100644
--- a/security/cryptopp/distinfo
+++ b/security/cryptopp/distinfo
@@ -1,2 +1,2 @@
-MD5 (crypto52.zip) = 5c09d632ef36e889f1727fb50cb21c4d
-SIZE (crypto52.zip) = 1045252
+MD5 (cryptopp521.zip) = 82a00c44235ccbae2bedf9cb16c40ac3
+SIZE (cryptopp521.zip) = 1010937
diff --git a/security/cryptopp/files/patch-ab b/security/cryptopp/files/patch-ab
deleted file mode 100644
index 8111052c8287..000000000000
--- a/security/cryptopp/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- integer.cpp.orig Sun Jul 18 00:46:23 2004
-+++ integer.cpp Sun Jul 18 00:46:46 2004
-@@ -20,7 +20,7 @@
- #ifdef SSE2_INTRINSICS_AVAILABLE
- #ifdef __GNUC__
- #include <xmmintrin.h>
-- #include <malloc.h>
-+ #include <stdlib.h>
- #include <signal.h>
- #include <setjmp.h>
- #else
-@@ -56,7 +56,7 @@
- {
- void *p;
- #ifdef __GNUC__
-- while (!(p = memalign(16, sizeof(T)*n)))
-+ while (!(p = malloc(sizeof(T)*n)))
- #else
- while (!(p = _mm_malloc(sizeof(T)*n, 16)))
- #endif
diff --git a/security/cryptopp/pkg-plist b/security/cryptopp/pkg-plist
index 591dd17e31e4..78f8c59560f7 100644
--- a/security/cryptopp/pkg-plist
+++ b/security/cryptopp/pkg-plist
@@ -124,6 +124,6 @@ include/cryptopp/zinflate.h
include/cryptopp/zlib.h
lib/libcryptopp.a
@dirrm include/cryptopp
-%%PORTDOCS%%share/doc/cryptopp/README
-%%PORTDOCS%%share/doc/cryptopp/License
-%%PORTDOCS%%@dirrm share/doc/cryptopp
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/License
+%%PORTDOCS%%@dirrm %%DOCSDIR%%