aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-17 19:35:55 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-17 19:35:55 +0000
commitee16186324677990bb1e0e3973de5e5786f89527 (patch)
tree559278c02f8e410836557685a9747067ab41e983 /security/cryptopp
parent8a798e41adffa58a681d5757cca96531b78f5c90 (diff)
downloadports-ee16186324677990bb1e0e3973de5e5786f89527.tar.gz
ports-ee16186324677990bb1e0e3973de5e5786f89527.zip
Update to 5.2
Fix build with gcc-3.4 Assign maintainership to submitter. PR: ports/69204 Submitted by: Xin LI <delphij@frontfree.net>
Notes
Notes: svn path=/head/; revision=113869
Diffstat (limited to 'security/cryptopp')
-rw-r--r--security/cryptopp/Makefile34
-rw-r--r--security/cryptopp/distinfo4
-rw-r--r--security/cryptopp/files/patch-ab20
-rw-r--r--security/cryptopp/pkg-plist9
4 files changed, 36 insertions, 31 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 8a2356bf5210..807622028d7f 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cryptopp
-PORTVERSION= 5.1
-PORTREVISION= 2
+PORTVERSION= 5.2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.eskimo.com/~weidai/ \
@@ -17,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= crypto${PORTVERSION:S/.//g}
EXTRACT_SUFX= .zip
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= delphij@FreeBSD.org.cn
COMMENT= A free C++ class library of Cryptographic Primitives
NO_WRKSUBDIR= yes
@@ -26,27 +25,6 @@ EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-HEADERFILES= 3way.h adler32.h aes.h algebra.h algparam.h arc4.h \
- argnames.h asn.h base64.h basecode.h bench.h \
- blowfish.h blumshub.h cast.h cbcmac.h channels.h \
- config.h crc.h cryptlib.h default.h des.h dh.h dh2.h \
- diamond.h dmac.h dsa.h ec2n.h eccrypto.h ecp.h \
- elgamal.h eprecomp.h esign.h factory.h files.h \
- filters.h fips140.h fltrimpl.h gf256.h gf2_32.h gf2n.h \
- gfpcrypt.h gost.h gzip.h haval.h hex.h hmac.h \
- hrtimer.h ida.h idea.h integer.h iterhash.h lubyrack.h \
- luc.h mars.h md2.h md4.h md5.h md5mac.h mdc.h misc.h \
- modarith.h modes.h modexppc.h mqueue.h mqv.h \
- nbtheory.h network.h nr.h oaep.h oids.h osrng.h \
- panama.h pch.h pkcspad.h polynomi.h pssr.h pubkey.h \
- pwdbased.h queue.h rabin.h randpool.h rc2.h rc5.h \
- rc6.h rijndael.h ripemd.h rng.h rsa.h rw.h safer.h \
- seal.h secblock.h seckey.h serpent.h sha.h shark.h \
- simple.h skipjack.h smartptr.h socketft.h square.h \
- strciphr.h tea.h tiger.h trdlocal.h trunhash.h \
- twofish.h validate.h wait.h wake.h winpipes.h words.h \
- xormac.h xtr.h xtrcrypt.h zdeflate.h zinflate.h zlib.h
-
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${ARCH} != "alpha"
@@ -59,9 +37,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cryptest ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/libcryptopp.a ${PREFIX}/lib
${MKDIR} ${PREFIX}/include/cryptopp
-.for H in ${HEADERFILES}
- ${INSTALL_DATA} ${WRKSRC}/$H ${PREFIX}/include/cryptopp
-.endfor
+ (for i in `${FIND} ${WRKSRC}/ -name '*.h' \
+ -and -not -name 'dll.h' \
+ -and -not -name 'resource.h'`; do \
+ ${INSTALL_DATA} $$i ${PREFIX}/include/cryptopp; \
+ done)
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cryptopp
${CP} ${WRKSRC}/Readme.txt ${PREFIX}/share/doc/cryptopp/README
diff --git a/security/cryptopp/distinfo b/security/cryptopp/distinfo
index bd122720ae3b..eec7bb90f224 100644
--- a/security/cryptopp/distinfo
+++ b/security/cryptopp/distinfo
@@ -1,2 +1,2 @@
-MD5 (crypto51.zip) = f4bfd4ac39dc1b7f0764d61a1ec4df16
-SIZE (crypto51.zip) = 829560
+MD5 (crypto52.zip) = 5c09d632ef36e889f1727fb50cb21c4d
+SIZE (crypto52.zip) = 1045252
diff --git a/security/cryptopp/files/patch-ab b/security/cryptopp/files/patch-ab
new file mode 100644
index 000000000000..8111052c8287
--- /dev/null
+++ b/security/cryptopp/files/patch-ab
@@ -0,0 +1,20 @@
+--- integer.cpp.orig Sun Jul 18 00:46:23 2004
++++ integer.cpp Sun Jul 18 00:46:46 2004
+@@ -20,7 +20,7 @@
+ #ifdef SSE2_INTRINSICS_AVAILABLE
+ #ifdef __GNUC__
+ #include <xmmintrin.h>
+- #include <malloc.h>
++ #include <stdlib.h>
+ #include <signal.h>
+ #include <setjmp.h>
+ #else
+@@ -56,7 +56,7 @@
+ {
+ void *p;
+ #ifdef __GNUC__
+- while (!(p = memalign(16, sizeof(T)*n)))
++ while (!(p = malloc(sizeof(T)*n)))
+ #else
+ while (!(p = _mm_malloc(sizeof(T)*n, 16)))
+ #endif
diff --git a/security/cryptopp/pkg-plist b/security/cryptopp/pkg-plist
index 1a911d4389fc..591dd17e31e4 100644
--- a/security/cryptopp/pkg-plist
+++ b/security/cryptopp/pkg-plist
@@ -1,5 +1,4 @@
bin/cryptest
-lib/libcryptopp.a
include/cryptopp/3way.h
include/cryptopp/adler32.h
include/cryptopp/aes.h
@@ -8,11 +7,13 @@ include/cryptopp/algparam.h
include/cryptopp/arc4.h
include/cryptopp/argnames.h
include/cryptopp/asn.h
+include/cryptopp/base32.h
include/cryptopp/base64.h
include/cryptopp/basecode.h
include/cryptopp/bench.h
include/cryptopp/blowfish.h
include/cryptopp/blumshub.h
+include/cryptopp/camellia.h
include/cryptopp/cast.h
include/cryptopp/cbcmac.h
include/cryptopp/channels.h
@@ -23,7 +24,6 @@ include/cryptopp/default.h
include/cryptopp/des.h
include/cryptopp/dh.h
include/cryptopp/dh2.h
-include/cryptopp/diamond.h
include/cryptopp/dmac.h
include/cryptopp/dsa.h
include/cryptopp/ec2n.h
@@ -95,21 +95,25 @@ include/cryptopp/secblock.h
include/cryptopp/seckey.h
include/cryptopp/serpent.h
include/cryptopp/sha.h
+include/cryptopp/shacal2.h
include/cryptopp/shark.h
include/cryptopp/simple.h
include/cryptopp/skipjack.h
include/cryptopp/smartptr.h
include/cryptopp/socketft.h
include/cryptopp/square.h
+include/cryptopp/stdcpp.h
include/cryptopp/strciphr.h
include/cryptopp/tea.h
include/cryptopp/tiger.h
include/cryptopp/trdlocal.h
include/cryptopp/trunhash.h
+include/cryptopp/ttmac.h
include/cryptopp/twofish.h
include/cryptopp/validate.h
include/cryptopp/wait.h
include/cryptopp/wake.h
+include/cryptopp/whrlpool.h
include/cryptopp/winpipes.h
include/cryptopp/words.h
include/cryptopp/xormac.h
@@ -118,6 +122,7 @@ include/cryptopp/xtrcrypt.h
include/cryptopp/zdeflate.h
include/cryptopp/zinflate.h
include/cryptopp/zlib.h
+lib/libcryptopp.a
@dirrm include/cryptopp
%%PORTDOCS%%share/doc/cryptopp/README
%%PORTDOCS%%share/doc/cryptopp/License