aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2-saslauthd
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2016-03-02 14:13:45 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2016-03-02 14:13:45 +0000
commitb49e7032a330a20d2c65ee8bc5d5052d6210d91d (patch)
tree0df689846593dab955ba5ea570d930631877a676 /security/cyrus-sasl2-saslauthd
parentc874aec956bcd8f31ed1341db73872992328dc86 (diff)
downloadports-b49e7032a330a20d2c65ee8bc5d5052d6210d91d.tar.gz
ports-b49e7032a330a20d2c65ee8bc5d5052d6210d91d.zip
- Make SASLdb excludable.
- Make SASLdb buildable with GDBM. - Make sure to disable the plugins where it is not required.
Notes
Notes: svn path=/head/; revision=409943
Diffstat (limited to 'security/cyrus-sasl2-saslauthd')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile36
1 files changed, 23 insertions, 13 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 976e66c17eac..dac2afc4aa78 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -11,25 +11,33 @@ INSTALL_WRKSRC= ${WRKSRC}/saslauthd
USE_RC_SUBR= saslauthd
-CONFIGURE_ARGS= --enable-login \
- --enable-auth-sasldb \
- --with-saslauthd=${SASLAUTHD_RUNPATH}
+CYRUS_CONFIGURE_ARGS= --with-saslauthd=${SASLAUTHD_RUNPATH}
CONFIGURE_ENV+= andrew_cv_runpath_switch=none
-OPTIONS_DEFINE= BDB DOCS OPENLDAP HTTPFORM
-BDB_CONFIGURE_ON= --with-dblib=berkeley \
- --with-bdb-libdir=${BDB_LIB_DIR} \
- --with-bdb-incdir=${BDB_INCLUDE_DIR} \
- --with-bdb=${BDB_LIB_NAME}
-BDB_USE= BDB=yes
-BDB_CONFIGURE_OFF= --with-dblib=ndbm
+OPTIONS_DEFINE= DOCS HTTPFORM OPENLDAP
+OPTIONS_RADIO= GSSAPI SASLDB
+OPTIONS_RADIO_SASLDB= BDB1 BDB GDBM
+OPTIONS_DEFAULT= BDB1
+
+HTTPFORM_DESC= Enable HTTP form authentication
+HTTPFORM_CONFIGURE_ENABLE=httpform
OPENLDAP_DESC= Use OpenLDAP
OPENLDAP_USE= OPENLDAP=yes
OPENLDAP_CONFIGURE_ON= --with-ldap=${LOCALBASE}
-HTTPFORM_DESC= Enable HTTP form authentication
-HTTPFORM_CONFIGURE_ENABLE=httpform
-OPTIONS_RADIO= GSSAPI
+SASLDB_DESC= Experimental SASLdb authentication module
+BDB_USE= BDB=yes
+BDB_CONFIGURE_ON= --enable-auth-sasldb \
+ --with-dblib=berkeley \
+ --with-bdb-libdir=${BDB_LIB_DIR} \
+ --with-bdb-incdir=${BDB_INCLUDE_DIR} \
+ --with-bdb=${BDB_LIB_NAME}
+BDB1_CONFIGURE_ON= --enable-auth-sasldb \
+ --with-dblib=ndbm
+GDBM_CONFIGURE_ON= --enable-auth-sasldb \
+ --with-dblib=gdbm \
+ --with-gdbm=${LOCALBASE}
+
.if exists(/usr/lib/libkrb5.a)
OPTIONS_RADIO_GSSAPI+= GSSAPI_BASE
OPTIONS_DEFAULT+= GSSAPI_BASE
@@ -45,4 +53,6 @@ GSSAPI_MIT_USES= gssapi:mit
GSSAPI_MIT_CONFIGURE_ON= --enable-gssapi="${GSSAPIBASEDIR}" \
--with-gss_impl=mit
+DOCS= AUTHORS COPYING ChangeLog INSTALL LDAP_SASLAUTHD NEWS README
+
.include "${.CURDIR}/../../security/cyrus-sasl2/Makefile.common"