aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-11-17 15:06:24 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-11-17 15:06:24 +0000
commiteebfde9690b057265c66f5ac6b108e6e720ff5da (patch)
tree3d1a4a9a7bf1cb9b889f5a5991cace634b82541b /security/cyrus-sasl2
parent96a0bdf09c799d713ce69f510face0d861de170d (diff)
downloadports-eebfde9690b057265c66f5ac6b108e6e720ff5da.tar.gz
ports-eebfde9690b057265c66f5ac6b108e6e720ff5da.zip
- Correct misspelling (PGK_PREFIX -> PKG_PREFIX) in pkg-install
- Add support for Heimdal Kerberos V port PR: 22894 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=35223
Diffstat (limited to 'security/cyrus-sasl2')
-rw-r--r--security/cyrus-sasl2/Makefile4
-rw-r--r--security/cyrus-sasl2/files/patch-ab4
-rw-r--r--security/cyrus-sasl2/pkg-install6
3 files changed, 8 insertions, 6 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 5f5dc34264c7..136622fe0e9c 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cyrus-sasl
PORTVERSION= 1.5.24
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/ \
${MASTER_SITE_LOCAL} \
@@ -72,6 +72,8 @@ SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
.if defined(KRB5_HOME) && exists(${KRB5_HOME})
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
+.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME})
+CONFIGURE_ARGS+= --enable-gssapi=${HEIMDAL_HOME}
.else
CONFIGURE_ARGS+= --disable-gssapi
GSSAPI= "@comment "
diff --git a/security/cyrus-sasl2/files/patch-ab b/security/cyrus-sasl2/files/patch-ab
index 00c61b875b68..403d1b8c8ace 100644
--- a/security/cyrus-sasl2/files/patch-ab
+++ b/security/cyrus-sasl2/files/patch-ab
@@ -1,5 +1,5 @@
--- configure.in.orig Thu Jul 20 21:35:01 2000
-+++ configure.in Tue Sep 19 21:51:11 2000
++++ configure.in Thu Nov 16 09:07:00 2000
@@ -66,8 +66,9 @@
dnl check for -R, etc. switch
CMU_GUESS_RUNPATH_SWITCH
@@ -7,8 +7,8 @@
-CPPFLAGS="-I/usr/local/include ${CPPFLAGS}"
-CMU_ADD_LIBPATH("/usr/local/lib")
+CPPFLAGS="-I${OPENSSLINC} -I${OPENSSLINC}/openssl ${CPPFLAGS}"
-+CMU_ADD_LIBPATH("${LOCALBASE}/lib")
+CMU_ADD_LIBPATH("${OPENSSLLIB}")
++CMU_ADD_LIBPATH("${LOCALBASE}/lib")
AM_DISABLE_STATIC
diff --git a/security/cyrus-sasl2/pkg-install b/security/cyrus-sasl2/pkg-install
index 785e57aea06e..816c8132ac4d 100644
--- a/security/cyrus-sasl2/pkg-install
+++ b/security/cyrus-sasl2/pkg-install
@@ -71,9 +71,9 @@ create_user() {
create_sasldb() {
if [ ! -f ${PGK_PREFIX}/etc/sasldb.db ]; then
- touch ${PGK_PREFIX}/etc/sasldb.db
- chown cyrus:mail ${PGK_PREFIX}/etc/sasldb.db
- chmod 640 ${PGK_PREFIX}/etc/sasldb.db
+ touch ${PKG_PREFIX}/etc/sasldb.db
+ chown cyrus:mail ${PKG_PREFIX}/etc/sasldb.db
+ chmod 640 ${PKG_PREFIX}/etc/sasldb.db
fi
}