aboutsummaryrefslogtreecommitdiff
path: root/security/dropbear/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-17 11:56:01 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-17 11:56:01 +0000
commit988c134834917d14b371e2e9441f6afb13e7b4b9 (patch)
tree732a6770d64c20443dcba101f2da9a8b15ab285a /security/dropbear/Makefile
parentf3a158d6b35413e1adfa4a380d2b5425d2826d36 (diff)
downloadports-988c134834917d14b371e2e9441f6afb13e7b4b9.tar.gz
ports-988c134834917d14b371e2e9441f6afb13e7b4b9.zip
- Update to version 0.39
PR: 60296 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=96043
Diffstat (limited to 'security/dropbear/Makefile')
-rw-r--r--security/dropbear/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/security/dropbear/Makefile b/security/dropbear/Makefile
index 1e43ee26427b..2ee30ef17ebd 100644
--- a/security/dropbear/Makefile
+++ b/security/dropbear/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dropbear
-PORTVERSION= 0.38
+PORTVERSION= 0.39
CATEGORIES= security ipv6
MASTER_SITES= http://matt.ucc.asn.au/dropbear/releases/
@@ -17,25 +17,26 @@ GNU_CONFIGURE= YES
USE_GMAKE= YES
USE_REINPLACE= YES
-.if defined(IS_STATIC)
+.if defined(WANT_STATIC)
CONFIGURE_ENV= LDFLAGS=-static
.endif
-MAKE_ENV+= INSTALL="${INSTALL}" INSTALL_PROGRAM="${INSTALL_PROGRAM}"
-post-configure:
- @${REINPLACE_CMD} -e "s,/etc/,${PREFIX}/etc/,g" ${WRKSRC}/options.h
- @${REINPLACE_CMD} -e "s,/usr/bin/X11/,${X11BASE}/,g" ${WRKSRC}/options.h
- @${REINPLACE_CMD} -e "s,^typedef int socklen_t,//typedef int socklen_t," \
- ${WRKSRC}/includes.h
- ${SED} -e 's:__PREFIX__:${PREFIX}:g' \
+post-patch:
+ @${REINPLACE_CMD} -e "s,_PRIV_FILENAME \"/etc/,_PRIV_FILENAME \"${PREFIX}/etc/,g; \
+ s,/usr/bin/X11/,${X11BASE}/,g" ${WRKSRC}/options.h
+ @${SED} -e 's:__PREFIX__:${PREFIX}:g' \
${FILESDIR}/dropbear.sh > ${WRKSRC}/dropbear.sh
post-install:
@${MKDIR} ${PREFIX}/etc/dropbear
-.if !defined(NOPORTDOC)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${ECHO_MSG} ""
@${INSTALL_SCRIPT} ${WRKSRC}/dropbear.sh ${PREFIX}/etc/rc.d/dropbear.sh.sample
+ @${ECHO_MSG} " Now you have to create your SSH host key."
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " To create RSA key:"
+ @${ECHO_MSG} " ${PREFIX}/sbin/dropbearkey -t rsa -f ${PREFIX}/etc/dropbear/dropbear_rsa_host_key"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " For more details, run ${PREFIX}/sbin/dropbearkey -h"
+ @${ECHO_MSG} ""
.include <bsd.port.mk>