aboutsummaryrefslogtreecommitdiff
path: root/security/easy-rsa/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2016-02-17 20:36:46 +0000
committerMatthias Andree <mandree@FreeBSD.org>2016-02-17 20:36:46 +0000
commitee8b19e7e638b691734e9e965eaf8619874162a5 (patch)
tree94a8d2582aa25c46856adcb11ba2d354a3028ea0 /security/easy-rsa/Makefile
parenta2194db8bac6d9995940f1cac86a6e798d05221e (diff)
downloadports-ee8b19e7e638b691734e9e965eaf8619874162a5.tar.gz
ports-ee8b19e7e638b691734e9e965eaf8619874162a5.zip
Install openssl-1.0.cnf as well (EasyRSA-3.0 specific).
Originally install it as ${DATADIR}/*.example and mark it as @sample in pkg-plist, so that it gets copied to the real file name on installation, and will not be removed if modified by the user. Submitted by: Michele Possamai (e-mail kept private)
Notes
Notes: svn path=/head/; revision=409070
Diffstat (limited to 'security/easy-rsa/Makefile')
-rw-r--r--security/easy-rsa/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/security/easy-rsa/Makefile b/security/easy-rsa/Makefile
index f708ab679a78..233db5c5b859 100644
--- a/security/easy-rsa/Makefile
+++ b/security/easy-rsa/Makefile
@@ -2,6 +2,7 @@
PORTNAME= easy-rsa
DISTVERSION= 3.0.1
+PORTREVISION= 1
CATEGORIES= security net-mgmt
MASTER_SITES= https://github.com/OpenVPN/easy-rsa/releases/download/${DISTVERSION}/
DISTNAME= EasyRSA-${DISTVERSION}
@@ -29,10 +30,11 @@ SUB_FILES= easyrsa
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKDIR}/easyrsa ${STAGEDIR}${PREFIX}/bin/
${MKDIR} ${STAGEDIR}${DATADIR}/x509-types/
+ ${INSTALL_SCRIPT} ${WRKDIR}/easyrsa ${STAGEDIR}${PREFIX}/bin/
${INSTALL_SCRIPT} ${WRKSRC}/easyrsa ${STAGEDIR}${DATADIR}/easyrsa.real
- ${INSTALL_DATA} ${WRKSRC}/vars.example ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/vars.example ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/openssl-1.0.cnf ${STAGEDIR}${DATADIR}/openssl-1.0.cnf.example
(cd ${WRKSRC}/x509-types/ && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}/x509-types/)
do-install-DOCS-on: