aboutsummaryrefslogtreecommitdiff
path: root/security/fakebo
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
commit4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448 (patch)
tree7d2afea24bed5487a0bed70a4ce863d70ee3d368 /security/fakebo
parentb3b7323d8ef412f19e96f476f048c4f46aa36bab (diff)
downloadports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.tar.gz
ports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.zip
STAGE support, and general cleanups. Some of the changes are a
bit more aggressive, but at this point, if I'm staging your port, you've likely stopped caring what's done to it.
Notes
Notes: svn path=/head/; revision=352710
Diffstat (limited to 'security/fakebo')
-rw-r--r--security/fakebo/Makefile20
-rw-r--r--security/fakebo/pkg-plist6
2 files changed, 14 insertions, 12 deletions
diff --git a/security/fakebo/Makefile b/security/fakebo/Makefile
index 121d5d00c4ee..caa107dd8f22 100644
--- a/security/fakebo/Makefile
+++ b/security/fakebo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fakebo
PORTVERSION= 0.4.2.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION:R}
@@ -17,22 +18,17 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
USE_AUTOTOOLS= aclocal autoheader automake autoconf
AUTOMAKE_ARGS= --add-missing
-MAN1= fakebo.1
-PORTDOCS= README custom.replies
-PLIST_FILES= bin/fakebo etc/fakebo.conf.sample
+PORT_OPTIONS= DOCS
-NO_STAGE= yes
post-extract:
@${FIND} ${WRKSRC} -type l -delete
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/fakebo ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/fakebo.1 ${MANPREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/fakebo.conf.dist ${PREFIX}/etc/fakebo.conf.sample
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/custom.replies ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/fakebo ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/fakebo.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/fakebo.conf.dist ${STAGEDIR}${PREFIX}/etc/fakebo.conf.sample
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/custom.replies ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/fakebo/pkg-plist b/security/fakebo/pkg-plist
new file mode 100644
index 000000000000..41d7e459b5a7
--- /dev/null
+++ b/security/fakebo/pkg-plist
@@ -0,0 +1,6 @@
+bin/fakebo
+@sample etc/fakebo.conf.sample
+man/man1/fakebo.1
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/custom.replies
+%%PORTDOCS%%@dirrm %%DOCSDIR%%