aboutsummaryrefslogtreecommitdiff
path: root/security/fwknop/Makefile
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-10-16 12:25:21 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-10-16 12:25:21 +0000
commit91364fbc63dc7d1b6365c2f588a9400c02f8fa91 (patch)
tree28f4ac7e93f6db6a471d71b207bfc9388162abb8 /security/fwknop/Makefile
parent49387e2eeda040e132b17677e3350945ec186daf (diff)
downloadports-91364fbc63dc7d1b6365c2f588a9400c02f8fa91.tar.gz
ports-91364fbc63dc7d1b6365c2f588a9400c02f8fa91.zip
security/fwknop: Update to 2.6.7
* Update to 2.6.7 * Update and sort pkg-plist * Group/sort sections * Convert to OPTIONS helpers * Use install-strip target so binaries/libraries are stripped PR: 203168 Submitted by: Sean Greven <sean.greven gmail com> (maintainer)
Notes
Notes: svn path=/head/; revision=399435
Diffstat (limited to 'security/fwknop/Makefile')
-rw-r--r--security/fwknop/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/security/fwknop/Makefile b/security/fwknop/Makefile
index b9ab715d32cd..e41e78f918d6 100644
--- a/security/fwknop/Makefile
+++ b/security/fwknop/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fwknop
-PORTVERSION= 2.5.1
-PORTREVISION= 3
+PORTVERSION= 2.6.7
CATEGORIES= security
MASTER_SITES= http://www.cipherdyne.org/fwknop/download/
@@ -12,22 +11,23 @@ COMMENT= SPA implementation for Linux and FreeBSD
LICENSE= GPLv2
+CPE_VENDOR= cipherdyne
+
OPTIONS_DEFINE= GPGME
OPTIONS_DEFAULT= GPGME
+
GPGME_DESC= Build support for gpgme
-INFO= libfko
+
USES= cpe libtool
-CPE_VENDOR= cipherdyne
-GNU_CONFIGURE= yes
-USE_RC_SUBR= fwknopd
USE_LDCONFIG= yes
+USE_RC_SUBR= fwknopd
-.include <bsd.port.options.mk>
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+INFO= libfko
-.if ${PORT_OPTIONS:MGPGME}
-LIB_DEPENDS+= libgpgme.so:${PORTSDIR}/security/gpgme
-.else
-CONFIGURE_ARGS+=--without-gpgme
-.endif
+GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
+GPGME_CONFIGURE_WITH= gpgme
.include <bsd.port.mk>