aboutsummaryrefslogtreecommitdiff
path: root/security/gnutls
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-14 20:51:32 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-14 20:51:32 +0000
commitce32977b20ed724bdf5a47bd519d4510228f64fa (patch)
tree0a392022a2d90a9d6a6589635431e097dfb01630 /security/gnutls
parent27c95ec807c800978071f21957f15e93cc37239b (diff)
downloadports-ce32977b20ed724bdf5a47bd519d4510228f64fa.tar.gz
ports-ce32977b20ed724bdf5a47bd519d4510228f64fa.zip
security/gnutls: unbreak aarch64 after r431214
lib/accelerated/aarch64/elf/aes-aarch64.s.tmp.S:5:1: error: unknown directive .arch armv8-a+crypto ^ lib/accelerated/aarch64/elf/aes-aarch64.s.tmp.S:49:2: error: instruction requires: crypto aese v6.16b,v0.16b ^ PR: 216045 Approved by: tijl (maintainer)
Notes
Notes: svn path=/head/; revision=431494
Diffstat (limited to 'security/gnutls')
-rw-r--r--security/gnutls/Makefile15
1 files changed, 12 insertions, 3 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 1f31e361086e..4ed724ab9639 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -20,8 +20,8 @@ LIB_DEPENDS= libgmp.so:math/gmp \
BUILD_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
RUN_DEPENDS+= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
-USES= cpe gmake iconv libtool localbase makeinfo pathfix pkgconfig \
- tar:xz
+USES= compiler cpe gmake iconv libtool localbase makeinfo \
+ pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-guile \
@@ -64,6 +64,15 @@ ZLIB_CONFIGURE_WITH= zlib
INFO= gnutls gnutls-guile
+.include <bsd.port.pre.mk>
+
+# XXX CHOSEN_COMPILER_VERSION isn't supported, so check CC hasn't changed
+.if ${ARCH} == aarch64 && ${CC} == cc && \
+ ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 40
+BUILD_DEPENDS+= as:devel/binutils
+CFLAGS+= -no-integrated-as
+.endif
+
post-patch:
@${RM} ${WRKSRC}/doc/*.info*
@@ -71,4 +80,4 @@ post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/doc/examples/*.[ch] ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>