aboutsummaryrefslogtreecommitdiff
path: root/security/gorilla
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 19:20:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 19:20:10 +0000
commit078531c5697ac479c671f5525ef6b901188354b0 (patch)
treecf45e21957d680153f7adc28d413f1d11e364992 /security/gorilla
parent7cac444be775865c82b5d7e88c3696cdafacaecf (diff)
downloadports-078531c5697ac479c671f5525ef6b901188354b0.tar.gz
ports-078531c5697ac479c671f5525ef6b901188354b0.zip
Password Gorilla is cross-platform Password Manager.
It uses TCL/Tk and runs on most platforms supported by Tcl/Tk. WWW: http://www.fpx.de/fp/Software/Gorilla PR: ports/93179 Submitted by: Kay Lehmann <kay_lehmann@web.de>
Notes
Notes: svn path=/head/; revision=157770
Diffstat (limited to 'security/gorilla')
-rw-r--r--security/gorilla/Makefile36
-rw-r--r--security/gorilla/distinfo3
-rw-r--r--security/gorilla/files/patch-gorilla.in8
-rw-r--r--security/gorilla/pkg-descr4
-rw-r--r--security/gorilla/pkg-plist29
5 files changed, 80 insertions, 0 deletions
diff --git a/security/gorilla/Makefile b/security/gorilla/Makefile
new file mode 100644
index 000000000000..a269d93f244d
--- /dev/null
+++ b/security/gorilla/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gorilla
+# Date created: 2006-02-11
+# Whom: Kay Lehmann <kay@bippes.finkenkrug.ev>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gorilla
+PORTVERSION= 1.3
+CATEGORIES= security
+MASTER_SITES= http://www.fpx.de/fp/Software/Gorilla/download/
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= Password Gorilla is cross-platform Password Manager
+
+BUILD_DEPENDS= wish${TK_VER}:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+LIB_DEPENDS= itcl32.1:${PORTSDIR}/lang/itcl
+RUN_DEPENDS= ${LOCALBASE}/lib/bwidget/init.tcl:${PORTSDIR}/x11-toolkits/bwidget
+
+USE_TCL= yes
+USE_TK= yes
+GNU_CONFIGURE= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/gorilla
+ @${INSTALL_DATA} ${WRKSRC}/*.tcl ${PREFIX}/lib/gorilla
+ ${TAR} -C ${WRKSRC} -cf - blowfish pics pwsafe twofish | \
+ ${TAR} -C ${PREFIX}/lib/gorilla --unlink -xf -
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+post-install:
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/gorilla
+ @${CHMOD} ugo+x ${PREFIX}/bin/gorilla
+
+.include <bsd.port.mk>
diff --git a/security/gorilla/distinfo b/security/gorilla/distinfo
new file mode 100644
index 000000000000..76fcfcb4bdb6
--- /dev/null
+++ b/security/gorilla/distinfo
@@ -0,0 +1,3 @@
+MD5 (gorilla-1.3.tar.gz) = 097f6824aba42c936d708f003d90f40f
+SHA256 (gorilla-1.3.tar.gz) = 6bfe6a99b0503c7017567d9eb0e184e15dbc1d753579005e3ed6baf49c3fed05
+SIZE (gorilla-1.3.tar.gz) = 177760
diff --git a/security/gorilla/files/patch-gorilla.in b/security/gorilla/files/patch-gorilla.in
new file mode 100644
index 000000000000..9cabdc5c4d80
--- /dev/null
+++ b/security/gorilla/files/patch-gorilla.in
@@ -0,0 +1,8 @@
+--- gorilla.in.orig Sun Dec 5 22:21:54 2004
++++ gorilla.in Sat Feb 11 12:30:44 2006
+@@ -7,4 +7,4 @@
+ }]} {
+ set myName $linkName
+ }
+-source [file join [file dirname $myName] gorilla.tcl]
++source [file join [file dirname $myName] @prefix@/lib/gorilla/gorilla.tcl]
diff --git a/security/gorilla/pkg-descr b/security/gorilla/pkg-descr
new file mode 100644
index 000000000000..b787355d452b
--- /dev/null
+++ b/security/gorilla/pkg-descr
@@ -0,0 +1,4 @@
+Password Gorilla is cross-platform Password Manager.
+It uses TCL/Tk and runs on most platforms supported by Tcl/Tk.
+
+WWW: http://www.fpx.de/fp/Software/Gorilla
diff --git a/security/gorilla/pkg-plist b/security/gorilla/pkg-plist
new file mode 100644
index 000000000000..b28a0070d40e
--- /dev/null
+++ b/security/gorilla/pkg-plist
@@ -0,0 +1,29 @@
+@comment $FreeBSD$
+bin/gorilla
+lib/gorilla/gorilla.tcl
+lib/gorilla/isaac.tcl
+lib/gorilla/blowfish/LICENSE.txt
+lib/gorilla/blowfish/blowfish.tcl
+lib/gorilla/blowfish/blowtest.tcl
+lib/gorilla/blowfish/pkgIndex.tcl
+lib/gorilla/pics/gorilla-16x16.gif
+lib/gorilla/pics/gorilla-32x32.gif
+lib/gorilla/pics/gorilla-48x48.gif
+lib/gorilla/pics/gorilla-logo.jpg
+lib/gorilla/pics/gorilla-splash.gif
+lib/gorilla/pics/gorilla.ico
+lib/gorilla/pwsafe/LICENSE.txt
+lib/gorilla/pwsafe/pkgIndex.tcl
+lib/gorilla/pwsafe/pwsafe-db.tcl
+lib/gorilla/pwsafe/pwsafe-int.tcl
+lib/gorilla/pwsafe/pwsafe-io.tcl
+lib/gorilla/pwsafe/pwsafe.dat
+lib/gorilla/pwsafe/pwsafe.tcl
+lib/gorilla/pwsafe/pwtest.tcl
+lib/gorilla/twofish/twofish.tcl
+lib/gorilla/twofish/twotest.tcl
+@dirrm lib/gorilla/blowfish
+@dirrm lib/gorilla/pics
+@dirrm lib/gorilla/twofish
+@dirrm lib/gorilla/pwsafe
+@dirrm lib/gorilla