aboutsummaryrefslogtreecommitdiff
path: root/security/gpgme
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-11 05:32:48 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-11 05:32:48 +0000
commit8967054a683476cdf3815ce4d3a8785cf144b435 (patch)
tree0d96c918d4119c8e9f5a37365d0fd6377ebeffae /security/gpgme
parent19ae22908e75570bbafd646d469dc1a121e73e79 (diff)
downloadports-8967054a683476cdf3815ce4d3a8785cf144b435.tar.gz
ports-8967054a683476cdf3815ce4d3a8785cf144b435.zip
Update to 1.0.1.
Notes
Notes: svn path=/head/; revision=123690
Diffstat (limited to 'security/gpgme')
-rw-r--r--security/gpgme/Makefile11
-rw-r--r--security/gpgme/distinfo4
-rw-r--r--security/gpgme/files/patch-assuan::assuan-socket-connect.c10
-rw-r--r--security/gpgme/files/patch-assuan::assuan-socket-server.c10
-rw-r--r--security/gpgme/files/patch-ltmain.sh15
-rw-r--r--security/gpgme/files/patch-tests::gpg::t-eventloop.c10
-rw-r--r--security/gpgme/pkg-plist5
7 files changed, 13 insertions, 52 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 1d06e7f2c43a..07d8661da61c 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gpgme
-PORTVERSION= 0.3.16
-PORTREVISION= 1
+PORTVERSION= 1.0.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gpgme
@@ -16,11 +15,14 @@ MAINTAINER= markun@onohara.to
COMMENT= A library to make access to GnuPG easier
BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
-LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth
-USE_INC_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
USE_GMAKE= yes
INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-pth \
+ --without-pth-test \
+ --with-gpg=${LOCALBASE}/bin/gpg
INFO= gpgme
@@ -32,6 +34,7 @@ WITH_GPGSM= yes
.if defined(WITH_GPGSM)
BUILD_DEPENDS+= gpgsm:${PORTSDIR}/security/gnupg-devel
+CONFIGURE_ARGS+=--with-gpgsm=${LOCALBASE}/bin/gpgsm
.else
CONFIGURE_ARGS+= --without-gpgsm
.endif
diff --git a/security/gpgme/distinfo b/security/gpgme/distinfo
index f992ae8f8519..28db7166f617 100644
--- a/security/gpgme/distinfo
+++ b/security/gpgme/distinfo
@@ -1,2 +1,2 @@
-MD5 (gpgme-0.3.16.tar.gz) = 0476b219695ea25cb2a97b18b717e381
-SIZE (gpgme-0.3.16.tar.gz) = 679430
+MD5 (gpgme-1.0.1.tar.gz) = 915045809b729998e4b7cb58856550a4
+SIZE (gpgme-1.0.1.tar.gz) = 815046
diff --git a/security/gpgme/files/patch-assuan::assuan-socket-connect.c b/security/gpgme/files/patch-assuan::assuan-socket-connect.c
deleted file mode 100644
index 74acc38ea626..000000000000
--- a/security/gpgme/files/patch-assuan::assuan-socket-connect.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- assuan/assuan-socket-connect.c.orig Wed Jan 29 15:30:12 2003
-+++ assuan/assuan-socket-connect.c Wed Jan 29 15:30:28 2003
-@@ -23,6 +23,7 @@
- #include <stddef.h>
- #include <stdio.h>
- #include <errno.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/un.h>
- #include <unistd.h>
diff --git a/security/gpgme/files/patch-assuan::assuan-socket-server.c b/security/gpgme/files/patch-assuan::assuan-socket-server.c
deleted file mode 100644
index af8a39751c34..000000000000
--- a/security/gpgme/files/patch-assuan::assuan-socket-server.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- assuan/assuan-socket-server.c.orig Wed Jan 29 15:27:13 2003
-+++ assuan/assuan-socket-server.c Wed Jan 29 15:27:38 2003
-@@ -22,6 +22,7 @@
- #include <stdlib.h>
- #include <stdio.h>
- #include <errno.h>
-+#include <sys/types.h>
- #include <sys/socket.h>
- #include <sys/un.h>
- #include <unistd.h>
diff --git a/security/gpgme/files/patch-ltmain.sh b/security/gpgme/files/patch-ltmain.sh
deleted file mode 100644
index 85e86e5ae349..000000000000
--- a/security/gpgme/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Tue Dec 30 09:32:46 2003
-+++ ltmain.sh Tue Dec 30 09:32:59 2003
-@@ -4333,10 +4333,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/security/gpgme/files/patch-tests::gpg::t-eventloop.c b/security/gpgme/files/patch-tests::gpg::t-eventloop.c
deleted file mode 100644
index d8149c9ef186..000000000000
--- a/security/gpgme/files/patch-tests::gpg::t-eventloop.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- tests/gpg/t-eventloop.c.orig Fri Aug 30 17:22:54 2002
-+++ tests/gpg/t-eventloop.c Fri Aug 30 17:21:50 2002
-@@ -24,6 +24,7 @@
- #include <string.h>
- #include <assert.h>
- #include <errno.h>
-+#include <sys/types.h>
- #include <sys/select.h>
-
- #include <gpgme.h>
diff --git a/security/gpgme/pkg-plist b/security/gpgme/pkg-plist
index 0a003a2416f1..f41295854706 100644
--- a/security/gpgme/pkg-plist
+++ b/security/gpgme/pkg-plist
@@ -1,6 +1,9 @@
bin/gpgme-config
include/gpgme.h
+lib/libgpgme-pthread.a
+lib/libgpgme-pthread.so
+lib/libgpgme-pthread.so.14
lib/libgpgme.a
lib/libgpgme.so
-lib/libgpgme.so.9
+lib/libgpgme.so.14
share/aclocal/gpgme.m4