aboutsummaryrefslogtreecommitdiff
path: root/security/gringotts
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-07-06 16:54:46 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-07-06 16:54:46 +0000
commit000c89ee2ea50a57623fd5554053da50e10696c4 (patch)
treee0300b6981c1476a4bf8b9e494379561911b46cf /security/gringotts
parent7219c6847f410344c3d7fedf5f9aaebecd04b8b0 (diff)
downloadports-000c89ee2ea50a57623fd5554053da50e10696c4.tar.gz
ports-000c89ee2ea50a57623fd5554053da50e10696c4.zip
Add gringotts, a GTK application for securely storing sensitive data.
Notes
Notes: svn path=/head/; revision=62522
Diffstat (limited to 'security/gringotts')
-rw-r--r--security/gringotts/Makefile39
-rw-r--r--security/gringotts/distinfo1
-rw-r--r--security/gringotts/files/gnomeless-Makefile.in11
-rw-r--r--security/gringotts/files/patch-Makefile.in16
-rw-r--r--security/gringotts/files/patch-grg_safe.c49
-rw-r--r--security/gringotts/files/patch-gringotts.in10
-rw-r--r--security/gringotts/files/patch-src-Makefile.in10
-rw-r--r--security/gringotts/pkg-comment1
-rw-r--r--security/gringotts/pkg-descr22
-rw-r--r--security/gringotts/pkg-plist15
10 files changed, 174 insertions, 0 deletions
diff --git a/security/gringotts/Makefile b/security/gringotts/Makefile
new file mode 100644
index 000000000000..321a5b674985
--- /dev/null
+++ b/security/gringotts/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: gringotts
+# Date created: 02 July 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gringotts
+PORTVERSION= 0.5.9
+CATEGORIES= security
+MASTER_SITES= http://devel.pluto.linux.it/projects/Gringotts/current/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+
+MAINTAINER= anders@FreeBSD.org
+
+LIB_DEPENDS= mcrypt.7:${PORTSDIR}/security/libmcrypt \
+ mhash.2:${PORTSDIR}/security/mhash \
+ gtk-x11-2.0.0:${PORTSDIR}/x11-toolkits/gtk20 \
+ popt.0:${PORTSDIR}/devel/popt
+
+USE_BZIP2= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ARGS+= --disable-env-check
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+WANT_GNOME= yes
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+.else
+
+post-patch:
+ @${PATCH} < ${FILESDIR}/gnomeless-Makefile.in \
+ ${WRKSRC}/Makefile.in >/dev/null 2>&1
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/gringotts/distinfo b/security/gringotts/distinfo
new file mode 100644
index 000000000000..3f9a2ea03e09
--- /dev/null
+++ b/security/gringotts/distinfo
@@ -0,0 +1 @@
+MD5 (gringotts-0.5.9.tar.bz2) = 24ca09631fce1f3e294b15b1bd49239d
diff --git a/security/gringotts/files/gnomeless-Makefile.in b/security/gringotts/files/gnomeless-Makefile.in
new file mode 100644
index 000000000000..2716116e739e
--- /dev/null
+++ b/security/gringotts/files/gnomeless-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Sat Jul 6 16:04:36 2002
++++ Makefile.in Sat Jul 6 16:05:17 2002
+@@ -366,7 +366,7 @@
+ install-data: install-data-recursive
+
+ install-am: all-am
+- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
++ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am
+ install: install-recursive
+ uninstall-am: uninstall-DsktpDATA uninstall-local
+ uninstall: uninstall-recursive
diff --git a/security/gringotts/files/patch-Makefile.in b/security/gringotts/files/patch-Makefile.in
new file mode 100644
index 000000000000..deeb568ee4be
--- /dev/null
+++ b/security/gringotts/files/patch-Makefile.in
@@ -0,0 +1,16 @@
+--- Makefile.in.orig Sun Jun 16 19:04:42 2002
++++ Makefile.in Fri Jul 5 18:39:27 2002
+@@ -440,10 +440,10 @@
+ @echo
+ @echo
+ @echo ----------------------------------------------------------------------
+- @echo md5sum of relevant files:
++ @echo md5 checksum of relevant files:
+ @echo
+- @md5sum $(DESTDIR)$(bindir)/gringotts-bin|(read A B; echo $$B ": " $$A)
+- @md5sum $(DESTDIR)$(libdir)/libgringotts.so|(read A B; echo $$B ": " $$A)
++ @md5 $(DESTDIR)$(bindir)/gringotts-bin|(read A B; echo $$B ": " $$A)
++ @md5 $(DESTDIR)$(libdir)/libgringotts.so|(read A B; echo $$B ": " $$A)
+ @echo
+ @echo use these values to check program integrity at any time
+ @echo ----------------------------------------------------------------------
diff --git a/security/gringotts/files/patch-grg_safe.c b/security/gringotts/files/patch-grg_safe.c
new file mode 100644
index 000000000000..eb2e024ffdaf
--- /dev/null
+++ b/security/gringotts/files/patch-grg_safe.c
@@ -0,0 +1,49 @@
+--- src/grg_safe.c.orig Sun Jun 16 18:41:21 2002
++++ src/grg_safe.c Fri Jul 5 19:12:36 2002
+@@ -24,13 +24,16 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
++#include <sys/types.h>
+ #include <regex.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <unistd.h>
+ #include <sys/mman.h>
++#ifdef HAVE_SYS_FSUID_H
+ #include <sys/fsuid.h>
+-#include <sys/types.h>
++#endif
++#include <sys/mman.h>
+
+ #include <gtk/gtk.h>
+ #include <gdk-pixbuf/gdk-pixbuf.h>
+@@ -131,12 +134,12 @@
+ if (!geteuid())
+ //the process is SUID root. I can mlockall() the memory in order to avoid swapping.
+ {
+- gint res = mlockall (MCL_FUTURE);
++// gint res = mlockall (MCL_FUTURE);
+
+- if (res)
+- g_critical ("%s", _("The process is setuid root, but I can't lock memory paging"));
+- else
+- mem_safe = TRUE;
++// if (res)
++// g_critical ("%s", _("The process is setuid root, but I can't lock memory paging"));
++// else
++// mem_safe = TRUE;
+
+ //drop root privileges
+ setuid(getuid());
+@@ -181,8 +184,8 @@
+
+ if (ulimit != '0')
+ {
+- g_critical ("%s", _("Your shell is configured to produce core dumps. I cannot go on. Please run gringotts via its shell script."));
+- return FALSE;
++ g_critical ("%s", _("Your shell is configured to produce core dumps."));
++// return FALSE;
+ }
+
+ //checks that stderr, stdin & stdout are opened
diff --git a/security/gringotts/files/patch-gringotts.in b/security/gringotts/files/patch-gringotts.in
new file mode 100644
index 000000000000..39352c86647d
--- /dev/null
+++ b/security/gringotts/files/patch-gringotts.in
@@ -0,0 +1,10 @@
+--- src/gringotts.in.orig Sat Apr 20 14:49:15 2002
++++ src/gringotts.in Fri Jul 5 19:09:14 2002
+@@ -1,5 +1,5 @@
+-#! /bin/bash
++#! /bin/sh
+ CORE_LIMIT=`ulimit -Sc`
+ ulimit -Sc 0
+-@bindir@/gringotts-bin "$@"
++gringotts-bin "$@"
+ ulimit -Sc $CORE_LIMIT
diff --git a/security/gringotts/files/patch-src-Makefile.in b/security/gringotts/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..7973324e8880
--- /dev/null
+++ b/security/gringotts/files/patch-src-Makefile.in
@@ -0,0 +1,10 @@
+--- src/Makefile.in.orig Sun Jun 16 19:04:43 2002
++++ src/Makefile.in Sat Jul 6 16:55:20 2002
+@@ -417,7 +417,6 @@
+ install-exec-local: gringotts
+ strip $(DESTDIR)$(bindir)/gringotts-bin
+ cp gringotts $(DESTDIR)$(bindir)
+- chmod u+s $(DESTDIR)$(bindir)/gringotts-bin
+
+ uninstall-local:
+ rm -f $(DESTDIR)$(bindir)/gringotts
diff --git a/security/gringotts/pkg-comment b/security/gringotts/pkg-comment
new file mode 100644
index 000000000000..d600cdd6154a
--- /dev/null
+++ b/security/gringotts/pkg-comment
@@ -0,0 +1 @@
+GTK application to securely store sensitive data
diff --git a/security/gringotts/pkg-descr b/security/gringotts/pkg-descr
new file mode 100644
index 000000000000..58a951f1e59f
--- /dev/null
+++ b/security/gringotts/pkg-descr
@@ -0,0 +1,22 @@
+Gringotts is an application to store sensitive data like passwords, pincodes,
+credit card numbers, etc. Features:
+
+* Fast, light GTK2 interface.
+* Good integration with GNOME, as well as all the other window managers.
+* High stress on safety & security.
+* Not only "normal" string passwords can be used, but any file can be the
+password to your data.
+* 8 encryption algorythms are available through the mcrypt library:
+RIJNDAEL-128 (AES), RIJNDAEL-256, SERPENT, TWOFISH, CAST 256, SAFER+, LOKI97,
+3DES.
+* 2 160-bit hash algorythms, used to generate the key: SHA1, RIPEMD160.
+* 2 compression types, with 4 compression levels each: ZLib, BZip2.
+* Complete & easy management of entries' order.
+* Complete Search function.
+* Very intuitive usability, you won't need any manual.
+* It comes with a thread-safe C library, libGringotts, that can be used in any
+other project to save data in files in a simple and safe way.
+
+WWW: http://devel.pluto.linux.it/projects/Gringotts/
+
+- Anders Nordby <anders@fix.no>
diff --git a/security/gringotts/pkg-plist b/security/gringotts/pkg-plist
new file mode 100644
index 000000000000..0a5158511333
--- /dev/null
+++ b/security/gringotts/pkg-plist
@@ -0,0 +1,15 @@
+bin/gringotts-bin
+bin/gringotts
+include/libgringotts.h
+lib/libgringotts.so.1
+lib/libgringotts.so
+lib/libgringotts.la
+lib/libgringotts.a
+lib/pkgconfig/libgringotts.pc
+share/pixmaps/gringotts.xpm
+share/locale/de/LC_MESSAGES/gringotts.mo
+share/locale/fr/LC_MESSAGES/gringotts.mo
+share/locale/it/LC_MESSAGES/gringotts.mo
+@unexec rmdir -p %D/share/locale/*/LC_MESSAGES 2>/dev/null || true
+%%GNOME:%%share/gnome/apps/Utilities/gringotts.desktop
+%%GNOME:%%@unexec rmdir -p %D/share/gnome/apps 2>/dev/null || true