aboutsummaryrefslogtreecommitdiff
path: root/security/gtkportscan
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-07-15 16:45:18 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-07-15 16:45:18 +0000
commit05a96e6af784a21923f6751d01dd9a1c14df0e52 (patch)
tree4bf2a05c2b49fd0e2b1d0662d5bd88a0748bedc5 /security/gtkportscan
parent179f9d996f48815f0ef219a2fe664f626b780228 (diff)
downloadports-05a96e6af784a21923f6751d01dd9a1c14df0e52.tar.gz
ports-05a96e6af784a21923f6751d01dd9a1c14df0e52.zip
- Use GTK_CONFIG instead of hardcoded gtk12-config
PR: 19930 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Notes
Notes: svn path=/head/; revision=30660
Diffstat (limited to 'security/gtkportscan')
-rw-r--r--security/gtkportscan/Makefile7
-rw-r--r--security/gtkportscan/files/patch-aa10
2 files changed, 8 insertions, 9 deletions
diff --git a/security/gtkportscan/Makefile b/security/gtkportscan/Makefile
index e7dc4479f50a..2fc2cb8c08c3 100644
--- a/security/gtkportscan/Makefile
+++ b/security/gtkportscan/Makefile
@@ -15,10 +15,9 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-WRKSRC= ${WRKDIR}/gtkportscan
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/gtkportscan ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/portscan ${PREFIX}/bin
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV= GTK_CONFIG="${GTK_CONFIG}"
.include <bsd.port.mk>
diff --git a/security/gtkportscan/files/patch-aa b/security/gtkportscan/files/patch-aa
index 5eb7398ac64d..9dc42a9ae276 100644
--- a/security/gtkportscan/files/patch-aa
+++ b/security/gtkportscan/files/patch-aa
@@ -1,20 +1,20 @@
---- Makefile.orig Thu Mar 11 01:58:41 1999
-+++ Makefile Sun Sep 12 20:59:30 1999
+--- Makefile.orig Thu Mar 11 17:58:41 1999
++++ Makefile Sun Jul 16 00:45:14 2000
@@ -1,21 +1,21 @@
-CC=gcc
-GTK_FLAGS=`gtk-config --cflags` `gtk-config --libs`
+CC?=gcc
-+GTK_FLAGS=`gtk12-config --cflags` `gtk12-config --libs`
++GTK_FLAGS=`$(GTK_CONFIG) --cflags` `$(GTK_CONFIG) --libs`
all: gtkportscan portscan
portscan: portscan.c
- $(CC) -O2 -Wall portscan.c -o portscan -g
-+ $(CC) $(CFLAgS) -Wall portscan.c -o portscan ${CFLAGS}
++ $(CC) $(CFLAGS) portscan.c -o portscan
gtkportscan: gtkportscan.c
- $(CC) -Wall $(GTK_FLAGS) gtkportscan.c -o gtkportscan -g
-+ $(CC) -Wall $(GTK_FLAGS) gtkportscan.c -o gtkportscan ${CFLAGS}
++ $(CC) $(CFLAGS) $(GTK_FLAGS) gtkportscan.c -o gtkportscan
install:
- cp portscan /usr/local/bin