aboutsummaryrefslogtreecommitdiff
path: root/security/hackbot
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 12:53:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-17 12:53:47 +0000
commitea485f28c68eed7b5e3fd6f208ea894a79f10fa1 (patch)
tree92243f81412d3b24c3c6ec9ec692b16c6add2a0e /security/hackbot
parent8d1da0d24a6f2c6377be456b544a58f2b9ce6adb (diff)
downloadports-ea485f28c68eed7b5e3fd6f208ea894a79f10fa1.tar.gz
ports-ea485f28c68eed7b5e3fd6f208ea894a79f10fa1.zip
New port: security/hackbot
Hackbot is a host exploration tool and bannergrabber. It scans numerous services and vulnerabilities. PR: ports/47021 Submitted by: Michael L. Hostbaek <mich@freebsdcluster.org>
Notes
Notes: svn path=/head/; revision=73342
Diffstat (limited to 'security/hackbot')
-rw-r--r--security/hackbot/Makefile34
-rw-r--r--security/hackbot/distinfo1
-rw-r--r--security/hackbot/pkg-comment1
-rw-r--r--security/hackbot/pkg-descr8
-rw-r--r--security/hackbot/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/security/hackbot/Makefile b/security/hackbot/Makefile
new file mode 100644
index 000000000000..f07e27a15748
--- /dev/null
+++ b/security/hackbot/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: hackbot
+# Date created: Mon Jan 13 15:44:35 GMT 2003
+# Whom: mich@freebsdcluster.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hackbot
+PORTVERSION= 2.18
+CATEGORIES= security
+MASTER_SITES= http://ws.obit.nl/hackbot/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mich@freebsdcluster.org
+
+USE_REINPLACE= YES
+USE_PERL5= YES
+NO_BUILD= YES
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local/etc/|${PREFIX}/etc/hackbot/|' ${WRKSRC}/hackbot.pl
+
+do-install:
+ ${MKDIR} ${PREFIX}/etc/hackbot
+ ${INSTALL_DATA} ${WRKSRC}/google.db ${PREFIX}/etc/hackbot/google.db
+ ${INSTALL_DATA} ${WRKSRC}/fingerprint.db ${PREFIX}/etc/hackbot/fingerprint.db
+ ${INSTALL_DATA} ${WRKSRC}/cgi.db ${PREFIX}/etc/hackbot/cgi.db
+ ${INSTALL_SCRIPT} ${WRKSRC}/hackbot.pl ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/hackbot.1.gz ${PREFIX}/man/man1/
+
+MAN1= hackbot.1
+
+.include <bsd.port.mk>
diff --git a/security/hackbot/distinfo b/security/hackbot/distinfo
new file mode 100644
index 000000000000..3f488ada7c9d
--- /dev/null
+++ b/security/hackbot/distinfo
@@ -0,0 +1 @@
+MD5 (hackbot-2.18.tgz) = 382ea0e00fe1caf16d6b8cf0d819a617
diff --git a/security/hackbot/pkg-comment b/security/hackbot/pkg-comment
new file mode 100644
index 000000000000..7cc17fd61994
--- /dev/null
+++ b/security/hackbot/pkg-comment
@@ -0,0 +1 @@
+A host exploration tool and bannergrabber
diff --git a/security/hackbot/pkg-descr b/security/hackbot/pkg-descr
new file mode 100644
index 000000000000..2d036f911325
--- /dev/null
+++ b/security/hackbot/pkg-descr
@@ -0,0 +1,8 @@
+Hackbot is a host exploration tool and bannergrabber. It scans numerous
+services and vulnerabilities.
+
+WWW: http://ws.obit.nl/
+AUTHOR: Marco van Berkum <m.v.berkum@obit.nl>
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/security/hackbot/pkg-plist b/security/hackbot/pkg-plist
new file mode 100644
index 000000000000..c0f0f6ed896c
--- /dev/null
+++ b/security/hackbot/pkg-plist
@@ -0,0 +1,5 @@
+bin/hackbot.pl
+etc/hackbot/google.db
+etc/hackbot/fingerprint.db
+etc/hackbot/cgi.db
+@dirrm etc/hackbot