aboutsummaryrefslogtreecommitdiff
path: root/security/hexl/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-07 08:10:04 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-07 08:27:36 +0000
commite7fe6916018d9844573d2f9d89dace13ceefe461 (patch)
tree8784b8007d098323236e2f1998f0d1395333d7c7 /security/hexl/files/patch-CMakeLists.txt
parent83ab0870a93320bac7e7ba0944f7e25a13c064b1 (diff)
downloadports-e7fe6916018d9844573d2f9d89dace13ceefe461.tar.gz
ports-e7fe6916018d9844573d2f9d89dace13ceefe461.zip
security/hexl: New port: Intel homomorphic encryption acceleration library
Diffstat (limited to 'security/hexl/files/patch-CMakeLists.txt')
-rw-r--r--security/hexl/files/patch-CMakeLists.txt30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/hexl/files/patch-CMakeLists.txt b/security/hexl/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..aff9c395dc11
--- /dev/null
+++ b/security/hexl/files/patch-CMakeLists.txt
@@ -0,0 +1,30 @@
+- workaround for hexl's failure to find cpu_features
+
+--- CMakeLists.txt.orig 2021-10-07 07:53:10 UTC
++++ CMakeLists.txt
+@@ -137,17 +137,17 @@ message(STATUS "CMAKE_INSTALL_PREFIX: ${CMAKE_INST
+ #------------------------------------------------------------------------------
+ # Third-party code...
+ #------------------------------------------------------------------------------
+-find_package(CpuFeatures CONFIG)
+-if (NOT CpuFeatures_FOUND)
++#find_package(CpuFeatures CONFIG)
++if (FALSE AND NOT CpuFeatures_FOUND)
+ message(STATUS "CpuFeatures: pre-installed CpuFeatures not found")
+ add_subdirectory(cmake/third-party/cpu-features)
+ else()
+- message(STATUS "CpuFeatures: found")
+- add_library(cpu_features ALIAS CpuFeatures::cpu_features)
+- get_target_property(
+- CpuFeatures_INCLUDE_DIR
+- CpuFeatures::cpu_features
+- INTERFACE_INCLUDE_DIRECTORIES)
++# message(STATUS "CpuFeatures: found")
++# add_library(cpu_features ALIAS CpuFeatures::cpu_features)
++# get_target_property(
++# CpuFeatures_INCLUDE_DIR
++# CpuFeatures::cpu_features
++# INTERFACE_INCLUDE_DIRECTORIES)
+ endif()
+
+ if (HEXL_TESTING OR HEXL_BENCHMARK OR HEXL_DEBUG)