aboutsummaryrefslogtreecommitdiff
path: root/security/highwayhash
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2020-09-24 21:03:54 +0000
committerMark Linimon <linimon@FreeBSD.org>2020-09-24 21:03:54 +0000
commit09417a164da71a6b0560242c12ebbbf460cd445f (patch)
tree481658bd336bc8ef073e3b43b3287c75660aba89 /security/highwayhash
parent464d40e0d0e7465dff5229553e9081df4b9ca76f (diff)
downloadports-09417a164da71a6b0560242c12ebbbf460cd445f.tar.gz
ports-09417a164da71a6b0560242c12ebbbf460cd445f.zip
Update the actual error message seen on powerpc64.
Allow building on powerpc64le, but assume it will fail the same was as on powerpc64. Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=549963
Diffstat (limited to 'security/highwayhash')
-rw-r--r--security/highwayhash/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/security/highwayhash/Makefile b/security/highwayhash/Makefile
index ef3749ec4493..df557762cb24 100644
--- a/security/highwayhash/Makefile
+++ b/security/highwayhash/Makefile
@@ -13,8 +13,9 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_aarch64= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'
-BROKEN_powerpc64= fails to compile: g++6: error: unrecognized command line option '-mavx2'
-ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64
+BROKEN_powerpc64= fails to compile: highwayhash/arch_specific.cc:153:32: error: too few arguments to function sysctlbyname
+BROKEN_powerpc64le= fails to compile: highwayhash/arch_specific.cc:153:32: error: too few arguments to function sysctlbyname
+ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64 powerpc64le
ONLY_FOR_ARCHS_REASON= Assembly is implemented only for specific architectures in highwayhash/tsc_timer.h
USES= compiler:c++11-lang gmake