aboutsummaryrefslogtreecommitdiff
path: root/security/highwayhash
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-09 16:29:49 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-12-09 16:29:49 +0000
commit0be729d74350f672eacdf631ec1bbd0358ff9b60 (patch)
treeab435a39aa7d0cd080843d4b18227d0e05e08ab3 /security/highwayhash
parentaa9d768cb0cc25bcd96d613a82a4e2b51a0edbab (diff)
downloadports-0be729d74350f672eacdf631ec1bbd0358ff9b60.tar.gz
ports-0be729d74350f672eacdf631ec1bbd0358ff9b60.zip
security/highwayhash: remove obviously wrong hunk that I somehow missed before
The function reads TimeBase frequency, not the CPU frequency.
Notes
Notes: svn path=/head/; revision=557378
Diffstat (limited to 'security/highwayhash')
-rw-r--r--security/highwayhash/Makefile1
-rw-r--r--security/highwayhash/files/patch-highwayhash_arch__specific.cc9
2 files changed, 1 insertions, 9 deletions
diff --git a/security/highwayhash/Makefile b/security/highwayhash/Makefile
index ea237114d7d0..46eb6876af2e 100644
--- a/security/highwayhash/Makefile
+++ b/security/highwayhash/Makefile
@@ -3,6 +3,7 @@
PORTNAME= highwayhash
PORTVERSION= g20201021
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security
diff --git a/security/highwayhash/files/patch-highwayhash_arch__specific.cc b/security/highwayhash/files/patch-highwayhash_arch__specific.cc
index 1ad490e397d6..d20ecf47a7c0 100644
--- a/security/highwayhash/files/patch-highwayhash_arch__specific.cc
+++ b/security/highwayhash/files/patch-highwayhash_arch__specific.cc
@@ -10,12 +10,3 @@
#endif
#endif
-@@ -174,7 +174,7 @@ double InvariantTicksPerSecond() {
- #elif __FreeBSD__
- static double cycles_per_second = 0;
- size_t length = sizeof(cycles_per_second);
-- sysctlbyname("kern.timecounter.tc.timebase.frequency", &cycles_per_second,
-+ sysctlbyname("dev.cpu.0.freq", &cycles_per_second,
- &length, NULL, 0);
- #endif
- return cycles_per_second;