aboutsummaryrefslogtreecommitdiff
path: root/security/highwayhash
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-10 11:37:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-10 11:37:02 +0000
commit65f41e9981cd9f95133b36087b17441f051e41e5 (patch)
tree909476676d1aad7cdf7bbaf2706e792aa364a9cd /security/highwayhash
parentc74246304e85d278fb73cab97729ce2cb15b68e5 (diff)
downloadports-65f41e9981cd9f95133b36087b17441f051e41e5.tar.gz
ports-65f41e9981cd9f95133b36087b17441f051e41e5.zip
security/highwayhash: fix build on powerpc64, powerpc64le and probably arm architectures
Remove superflous ). Add necessary ifdefs. MFH: 2020Q4 (fix build blanket)
Notes
Notes: svn path=/head/; revision=551915
Diffstat (limited to 'security/highwayhash')
-rw-r--r--security/highwayhash/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/highwayhash/Makefile b/security/highwayhash/Makefile
index df557762cb24..2fed45f9705c 100644
--- a/security/highwayhash/Makefile
+++ b/security/highwayhash/Makefile
@@ -13,8 +13,6 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_aarch64= fails to compile: /usr/lib/clang/5.0.0/include/mmintrin.h:47:5: use of undeclared identifier '__builtin_ia32_emms'
-BROKEN_powerpc64= fails to compile: highwayhash/arch_specific.cc:153:32: error: too few arguments to function sysctlbyname
-BROKEN_powerpc64le= fails to compile: highwayhash/arch_specific.cc:153:32: error: too few arguments to function sysctlbyname
ONLY_FOR_ARCHS= aarch64 amd64 powerpc powerpc64 powerpc64le
ONLY_FOR_ARCHS_REASON= Assembly is implemented only for specific architectures in highwayhash/tsc_timer.h
@@ -24,6 +22,15 @@ GH_ACCOUNT= google
GH_TAGNAME= 954e56589a7e75bad04f1063174d78f8c17a9b3a
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
+
+.if ${ARCH:Mpowerpc*}
+CXXFLAGS+= -mpower8-vector
+MAKE_ENV+= HH_POWER=1
+.elif ${ARCH} == aarch64 || ${ARCH:Marmv*}
+MAKE_ENV+= HH_ARM=1
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libhighwayhash.so