aboutsummaryrefslogtreecommitdiff
path: root/security/hydra
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2019-01-13 18:22:54 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2019-01-13 18:22:54 +0000
commit7ba47cf58207757ae7af8b03418af162a69c3755 (patch)
treeb66ccd38912dba71ba187e3046d26b928a7b3a13 /security/hydra
parent1148c80feaf62e628539794d46ecd8729a040527 (diff)
downloadports-7ba47cf58207757ae7af8b03418af162a69c3755.tar.gz
ports-7ba47cf58207757ae7af8b03418af162a69c3755.zip
security/hydra: update to 8.8
- switch to github - update to 8.8 - pet portlint
Notes
Notes: svn path=/head/; revision=490167
Diffstat (limited to 'security/hydra')
-rw-r--r--security/hydra/Makefile20
-rw-r--r--security/hydra/distinfo6
-rw-r--r--security/hydra/files/patch-hydra.h10
3 files changed, 20 insertions, 16 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index 7194ba869514..8b6aa3a40915 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= hydra
-PORTVERSION= 8.5
+DISTVERSIONPREFIX=v
+DISTVERSION= 8.8
CATEGORIES= security
-MASTER_SITES= https://www.thc.org/releases/ \
- PACKETSTORM/groups/thc/
MAINTAINER= rm@FreeBSD.org
COMMENT= Brute force attack utility working on multiple network services
@@ -17,12 +16,17 @@ LIB_DEPENDS= libidn.so:dns/libidn \
libpcre.so:devel/pcre \
libsasl2.so:security/cyrus-sasl2
-PLIST_FILES= bin/hydra bin/pw-inspector bin/dpl4hydra.sh bin/hydra-wizard.sh \
- man/man1/hydra.1.gz man/man1/pw-inspector.1.gz
-GNU_CONFIGURE= yes
USES= gmake localbase ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= vanhauser-thc
+GH_PROJECT= thc-hydra
+
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl=${OPENSSLINC} \
--with-ssl-lib=${OPENSSLLIB}
+PLIST_FILES= bin/hydra bin/pw-inspector bin/dpl4hydra.sh bin/hydra-wizard.sh \
+ man/man1/hydra.1.gz man/man1/pw-inspector.1.gz
OPTIONS_DEFINE= FIREBIRD SSH SVN X11
OPTIONS_DEFAULT=SSH
@@ -30,7 +34,7 @@ OPTIONS_EXCLUDE=NLS DOCS
FIREBIRD_USES= firebird
SVN_LIB_DEPENDS= libsvn_client-1.so:devel/subversion
SSH_LIB_DEPENDS= libssh.so.4:security/libssh
-X11_USES= gettext pkgconfig
+X11_USES= gettext gnome pkgconfig
X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
X11_USE= gnome=atk,cairo,gdkpixbuf2,glib20,gtk20,pango
@@ -39,7 +43,7 @@ X11_PLIST_FILES= bin/xhydra man/man1/xhydra.1.gz
.include <bsd.port.pre.mk>
.if ${SSL_DEFAULT:Mlibressl*}
-IGNORE= Detected LibreSSL (missing RSA_get0_key and others)
+IGNORE= detected LibreSSL (missing RSA_get0_key and others)
.endif
post-patch:
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index dbac579300e7..8536b3c4c7cd 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494705731
-SHA256 (hydra-8.5.tar.gz) = 557ab284f877aa6c8a26f7491c0373a84836593e5e0ca141b327035e7937dd6d
-SIZE (hydra-8.5.tar.gz) = 1214640
+TIMESTAMP = 1547401419
+SHA256 (vanhauser-thc-thc-hydra-v8.8_GH0.tar.gz) = bc895a7aebdf0279186d40140f0dc1546ac6f3a5c5bc9d13b13766bffea3e966
+SIZE (vanhauser-thc-thc-hydra-v8.8_GH0.tar.gz) = 1202992
diff --git a/security/hydra/files/patch-hydra.h b/security/hydra/files/patch-hydra.h
index 30c84b55ab7e..c99ec31dc97a 100644
--- a/security/hydra/files/patch-hydra.h
+++ b/security/hydra/files/patch-hydra.h
@@ -1,13 +1,13 @@
---- hydra.h.orig 2016-06-16 14:57:15 UTC
+--- hydra.h.orig 2019-01-02 12:38:23 UTC
+++ hydra.h
-@@ -31,10 +31,6 @@
- #endif
+@@ -38,10 +38,6 @@
+ #endif
#endif
-#ifdef LIBSSH
--#include <libssh/libssh.h>
+- #include <libssh/libssh.h>
-#endif
-
#ifdef HAVE_ZLIB
- #include <zlib.h>
+ #include <zlib.h>
#endif