aboutsummaryrefslogtreecommitdiff
path: root/security/hydra
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2013-12-29 19:02:08 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2013-12-29 19:02:08 +0000
commitf27e6db48731cfacc6df0e17816c7fadc5d53619 (patch)
treeb08f86da83cbe841a36a480811d06ef06d4df44a /security/hydra
parent98e01397ca0e6dd9d2c0f2c9b428a353210c7004 (diff)
downloadports-f27e6db48731cfacc6df0e17816c7fadc5d53619.tar.gz
ports-f27e6db48731cfacc6df0e17816c7fadc5d53619.zip
- update to 7.6
- enable ssh support by default (for package users) - use options helpers - add stage support - general clean-up
Notes
Notes: svn path=/head/; revision=338034
Diffstat (limited to 'security/hydra')
-rw-r--r--security/hydra/Makefile42
-rw-r--r--security/hydra/distinfo4
-rw-r--r--security/hydra/files/patch-Makefile.unix5
3 files changed, 19 insertions, 32 deletions
diff --git a/security/hydra/Makefile b/security/hydra/Makefile
index 6cf47fd98915..1c7682415564 100644
--- a/security/hydra/Makefile
+++ b/security/hydra/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hydra
-PORTVERSION= 7.5
+PORTVERSION= 7.6
CATEGORIES= security
MASTER_SITES= https://www.thc.org/releases/ \
PACKETSTORM/groups/thc/
@@ -18,57 +18,49 @@ LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
CONFLICTS_INSTALL= hydra-web-[0-9]*
-PLIST_FILES= bin/hydra bin/pw-inspector bin/dpl4hydra.sh
+PLIST_FILES= bin/hydra bin/pw-inspector bin/dpl4hydra.sh bin/hydra-wizard.sh \
+ man/man1/hydra.1.gz man/man1/pw-inspector.1.gz
GNU_CONFIGURE= yes
USES= gmake
USE_OPENSSL= yes
WANT_GNOME= yes
-MAN1= hydra.1 pw-inspector.1
-
OPTIONS_DEFINE= FIREBIRD SSH SVN X11
+OPTIONS_DEFAULT=SSH
OPTIONS_EXCLUDE=NLS DOCS
+FIREBIRD_LIB_DEPENDS= libfbclient.so:${PORTSDIR}/databases/firebird20-client
+SVN_LIB_DEPENDS= libsvn_client-1.so:${PORTSDIR}/devel/subversion
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MFIREBIRD}
-LIB_DEPENDS+= libfbclient.so:${PORTSDIR}/databases/firebird20-client
-.endif
-
.if ${PORT_OPTIONS:MSSH}
CFLAGS+= -I${LOCALBASE}/include
LIB_DEPENDS+= libssh.so.4:${PORTSDIR}/security/libssh
.endif
-.if ${PORT_OPTIONS:MSVN}
-LIB_DEPENDS+= libsvn_client-1.so:${PORTSDIR}/devel/subversion
-.endif
-
.if ${PORT_OPTIONS:MX11}
USES+= pkgconfig
USE_GNOME= gtk20
-PLIST_FILES+= bin/xhydra
-MAN1+= xhydra.1
+PLIST_FILES+= bin/xhydra man/man1/xhydra.1.gz
.else
CONFIGURE_ARGS+= --disable-xhydra
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|CC = gcc||; \
- s|-O2|${CFLAGS}|; s|md4\..||g' \
- ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e 's|CC=gcc||; s|-O3|${CFLAGS}|;' \
+ ${WRKSRC}/Makefile.am ${WRKSRC}/Makefile.unix
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hydra ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/pw-inspector ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/dpl4hydra.sh ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/hydra.1 ${MANPREFIX}/man/man1/hydra.1
- ${INSTALL_MAN} ${WRKSRC}/pw-inspector.1 ${MANPREFIX}/man/man1/pw-inspector.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/hydra ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/pw-inspector ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/dpl4hydra.sh ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/hydra-wizard.sh ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/hydra.1 ${STAGEDIR}${MANPREFIX}/man/man1/hydra.1
+ ${INSTALL_MAN} ${WRKSRC}/pw-inspector.1 ${STAGEDIR}${MANPREFIX}/man/man1/pw-inspector.1
.if ${PORT_OPTIONS:MX11}
- ${INSTALL_PROGRAM} ${WRKSRC}/hydra-gtk/src/xhydra ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/xhydra.1 ${MANPREFIX}/man/man1/xhydra.1
+ ${INSTALL_PROGRAM} ${WRKSRC}/hydra-gtk/src/xhydra ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xhydra.1 ${STAGEDIR}${MANPREFIX}/man/man1/xhydra.1
.endif
.include <bsd.port.mk>
diff --git a/security/hydra/distinfo b/security/hydra/distinfo
index 9f5f2ee946da..aada66d5c3d8 100644
--- a/security/hydra/distinfo
+++ b/security/hydra/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hydra-7.5.tar.gz) = 7293e7c32198219688e5bf5308f7e8eab37ad78d49701c9860a6b22aecda0ab6
-SIZE (hydra-7.5.tar.gz) = 681784
+SHA256 (hydra-7.6.tar.gz) = a479bebabcb81c4a08a25f41c88688055bbb800ecfa93e25dd809ad1ff58debd
+SIZE (hydra-7.6.tar.gz) = 557045
diff --git a/security/hydra/files/patch-Makefile.unix b/security/hydra/files/patch-Makefile.unix
deleted file mode 100644
index c7d3f6fe4840..000000000000
--- a/security/hydra/files/patch-Makefile.unix
+++ /dev/null
@@ -1,5 +0,0 @@
---- ./Makefile.unix.orig 2011-07-18 21:38:43.000000000 -0400
-+++ ./Makefile.unix 2011-07-18 21:38:52.000000000 -0400
-@@ -1,2 +1 @@
--CC=gcc
- STRIP=strip