aboutsummaryrefslogtreecommitdiff
path: root/security/idea/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
commitc4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8 (patch)
tree98f96307b5a32cecd5d4e2104c22673c560b9789 /security/idea/Makefile
parent56b2cbf1c5abcce2be96f0aa252e4df4d8d99dd2 (diff)
downloadports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.tar.gz
ports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.zip
- Use DOC instead of NOPORTDOCS
- Pacify portlint - Convert header
Notes
Notes: svn path=/head/; revision=310443
Diffstat (limited to 'security/idea/Makefile')
-rw-r--r--security/idea/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/security/idea/Makefile b/security/idea/Makefile
index 9b4a3a3977fd..32c58f8aa4a8 100644
--- a/security/idea/Makefile
+++ b/security/idea/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: idea
-# Date created: 4 September 2004
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= idea
PORTVERSION= 1.2
@@ -30,6 +26,10 @@ MANCOMPRESSED= no
IGNORE= you chose not to use idea related code
.endif
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-build:
${CC} ${WRKSRC}/idea.c ${WRKSRC}/idea_cmd.c ${CFLAGS} -o ${WRKSRC}/${PORTNAME}
@@ -39,7 +39,7 @@ do-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Examples ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/byte_ord.ps ${WRKSRC}/idea_cmd.txt ${DOCSDIR}
.endif