aboutsummaryrefslogtreecommitdiff
path: root/security/identify
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-24 09:02:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-24 09:02:54 +0000
commitfcf18b10a419933be59d39de86c4f50023817bcb (patch)
tree357a2cc8187eb638a02cafcbac419a05a8813f8a /security/identify
parent9782c85d2d65cb9eca91a6803b01edebc1c28f2b (diff)
downloadports-fcf18b10a419933be59d39de86c4f50023817bcb.tar.gz
ports-fcf18b10a419933be59d39de86c4f50023817bcb.zip
- Add LICENSE
- Switch to options helpers - Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=413927
Diffstat (limited to 'security/identify')
-rw-r--r--security/identify/Makefile4
-rw-r--r--security/identify/files/patch-Makefile4
-rw-r--r--security/identify/files/patch-identify.c14
3 files changed, 13 insertions, 9 deletions
diff --git a/security/identify/Makefile b/security/identify/Makefile
index 9c6abdb5db78..6548ae9ba9fd 100644
--- a/security/identify/Makefile
+++ b/security/identify/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://ftp.nluug.nl/ftp/pub/pub/security/coast/daemons/pidentd/too
MAINTAINER= ports@FreeBSD.org
COMMENT= Client side ident protocol daemon wrapper
+LICENSE= PD
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libident.a:security/libident
PORTDOCS= README
@@ -19,6 +21,8 @@ OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/identify ${STAGEDIR}${PREFIX}/libexec
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
diff --git a/security/identify/files/patch-Makefile b/security/identify/files/patch-Makefile
index 40a923b1a659..801f252555aa 100644
--- a/security/identify/files/patch-Makefile
+++ b/security/identify/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Mon Jul 20 09:01:27 1992
-+++ Makefile Fri Apr 2 10:50:40 1999
+--- Makefile.orig 1992-07-20 16:01:27 UTC
++++ Makefile
@@ -1,2 +1,11 @@
-identify: identify.c
- $(CC) -o identify identify.c -lauthuser
diff --git a/security/identify/files/patch-identify.c b/security/identify/files/patch-identify.c
index 75cb4dcb71f0..d35792156ae0 100644
--- a/security/identify/files/patch-identify.c
+++ b/security/identify/files/patch-identify.c
@@ -1,5 +1,5 @@
---- identify.c.orig Tue Feb 2 01:51:57 1993
-+++ identify.c Sun Oct 20 17:53:44 2002
+--- identify.c.orig 1993-02-02 09:51:57 UTC
++++ identify.c
@@ -11,7 +11,7 @@
#include <stdio.h>
#include <signal.h>
@@ -9,7 +9,7 @@
#include <netdb.h>
#include <sys/types.h>
#include <netinet/in.h>
-@@ -33,57 +33,43 @@
+@@ -33,57 +33,43 @@ char *force_log = NULL;
int noidentify = 0;
int bits = 0;
int reject_flag = 0;
@@ -84,7 +84,7 @@
host[len] = '\0';
}
-@@ -91,16 +77,7 @@
+@@ -91,16 +77,7 @@ char *ident_get_identifier(fd, host, len
if (noidentify)
return NULL;
else
@@ -102,7 +102,7 @@
}
-@@ -128,10 +105,6 @@
+@@ -128,10 +105,6 @@ main(argc,argv)
timeout = atoi(argv[i]+2);
break;
@@ -113,7 +113,7 @@
case 'R':
if (!argv[i][2])
reject_flag = 1;
-@@ -200,7 +173,7 @@
+@@ -200,7 +173,7 @@ main(argc,argv)
{
/* In child, let's fork again so we can forget about this child */
if (fork())
@@ -122,7 +122,7 @@
}
else
{
-@@ -241,13 +214,13 @@
+@@ -241,13 +214,13 @@ main(argc,argv)
}
}