aboutsummaryrefslogtreecommitdiff
path: root/security/john/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-10-19 07:48:36 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-10-19 07:48:36 +0000
commit809fe307f02ed333ae4e3ce3325df958e19c3ab1 (patch)
tree562c86436bf0c38bff302d96f192d607e4377d18 /security/john/Makefile
parent9effd49f06e41e3cdd66d7797a0fa1f7ac971dd2 (diff)
downloadports-809fe307f02ed333ae4e3ce3325df958e19c3ab1.tar.gz
ports-809fe307f02ed333ae4e3ce3325df958e19c3ab1.zip
security/john: try to fix the port's build on AArch64
In commit 1e6670382fbb, the observed failure on PowerPC had been mended in a way that broke AArch64 build. Robert's investigation had shown that <altivec.h> should've been included elsewhere, and it actually is, but guarded by `#ifdef __linux__' for some reason. Alexander explained that at the time the AltiVec support was just for two platforms: macOS (first) and Linux (added later). If the guard of `#include <altivec.h>' was needed, then we could probably replace the `#ifdef __linux__' with `#ifndef __APPLE__' for the same effect on old macOS versions which do not need the #include. PR: 266732 Submitted by: Robert Clausecker Discussed with: Solar Designer
Diffstat (limited to 'security/john/Makefile')
-rw-r--r--security/john/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/security/john/Makefile b/security/john/Makefile
index 1358642f6165..8822f293079c 100644
--- a/security/john/Makefile
+++ b/security/john/Makefile
@@ -51,6 +51,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' ${WRKSRC}/params.h
@${REINPLACE_CMD} -e '/^host_cpu=/s|$$| ; case $$host_cpu in\
amd64) host_cpu=x86_64 ;; esac|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's,^#ifdef __linux,#ifndef __APPLE,' \
+ ${WRKSRC}/DES_bs_b.c
do-install:
.for b in ${BINARIES}