aboutsummaryrefslogtreecommitdiff
path: root/security/kc/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2013-04-18 06:18:35 +0000
committerCarlo Strub <cs@FreeBSD.org>2013-04-18 06:18:35 +0000
commite76957aee5a284036a10ed11735a46b4223592eb (patch)
tree4c7e25fbc3267f4836ed7b8881dd7afc57302055 /security/kc/Makefile
parent9a0f3f88eb3e3d8b58932c408810d551045a6679 (diff)
downloadports-e76957aee5a284036a10ed11735a46b4223592eb.tar.gz
ports-e76957aee5a284036a10ed11735a46b4223592eb.zip
Console based password storing application using an encrypted XML
document as its database. WWW: http://keychain.googlecode.com PR: ports/177191 Submitted by: LEVAI Daniel <leva@ecentrum.hu> Feature safe: yes
Notes
Notes: svn path=/head/; revision=316020
Diffstat (limited to 'security/kc/Makefile')
-rw-r--r--security/kc/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/security/kc/Makefile b/security/kc/Makefile
new file mode 100644
index 000000000000..36209fcd12b0
--- /dev/null
+++ b/security/kc/Makefile
@@ -0,0 +1,31 @@
+# Created by: LEVAI Daniel <leva@ecentrum.hu>
+# $FreeBSD$
+
+PORTNAME= kc
+PORTVERSION= 2.3.0
+CATEGORIES= security
+MASTER_SITES= http://keychain.googlecode.com/files/
+
+MAINTAINER= leva@ecentrum.hu
+COMMENT= Console based password storing application
+
+LICENSE= BSD
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
+ pcre:${PORTSDIR}/devel/pcre
+RUN_DEPENDS= p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
+
+MAN1= kc.1
+MANCOMPRESSED= yes
+
+PLIST_DIRS= share/kc
+PLIST_FILES= bin/kc \
+ share/kc/pwsafe_to_kc.pl
+
+MAKE_ENV+= HAVE_PCRE=yes
+
+post-install:
+ ${INSTALL} -d ${PREFIX}/share/kc
+ ${INSTALL} ${WRKSRC}/pwsafe_to_kc.pl ${PREFIX}/share/kc/
+
+.include <bsd.port.mk>