aboutsummaryrefslogtreecommitdiff
path: root/security/keepassxc
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-03-24 20:53:48 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-03-24 20:53:48 +0000
commitc6eceeb0ec6149078643aa0bfae9fcbcbb332ae4 (patch)
tree317a00f6925e47f0f7ca87531cce95ebc76db832 /security/keepassxc
parent937d27c43a000264defd24655b1fd71ae8907b8a (diff)
downloadports-c6eceeb0ec6149078643aa0bfae9fcbcbb332ae4.tar.gz
ports-c6eceeb0ec6149078643aa0bfae9fcbcbb332ae4.zip
security/keepassxc: update 2.3.4 -> 2.4.0
- removed deprecated KeePassHTTP option - added KeeShare option (Sharing integration with KeeShare) PR: 236726 Submitted by: Andrew Romanenko <melanhit@gmail.com> Relnotes: https://github.com/keepassxreboot/keepassxc/blob/develop/CHANGELOG
Notes
Notes: svn path=/head/; revision=496782
Diffstat (limited to 'security/keepassxc')
-rw-r--r--security/keepassxc/Makefile23
-rw-r--r--security/keepassxc/distinfo6
-rw-r--r--security/keepassxc/files/patch-CMakeLists.txt6
-rw-r--r--security/keepassxc/files/patch-src_gui_entry_EditEntryWidget.cpp13
-rw-r--r--security/keepassxc/pkg-descr12
-rw-r--r--security/keepassxc/pkg-plist34
6 files changed, 43 insertions, 51 deletions
diff --git a/security/keepassxc/Makefile b/security/keepassxc/Makefile
index d8137f703f26..6c39e8521c22 100644
--- a/security/keepassxc/Makefile
+++ b/security/keepassxc/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= keepassxc
-DISTVERSION= 2.3.4
-PORTREVISION= 3
+DISTVERSION= 2.4.0
CATEGORIES= security
MASTER_SITES= https://github.com/keepassxreboot/keepassxc/releases/download/${DISTVERSION}/${PORTNAME}-${DISTVERSION}-src.tar.xz?dummy=/
@@ -22,12 +21,13 @@ LICENSE_PERMS_NOKIA-LGPL-EXCEPTION= dist-mirror dist-sell pkg-mirror pkg-sell au
LIB_DEPENDS= libargon2.so:security/libargon2 \
libcurl.so:ftp/curl \
libgcrypt.so:security/libgcrypt \
- libgpg-error.so:security/libgpg-error
+ libgpg-error.so:security/libgpg-error \
+ libqrencode.so:graphics/libqrencode
USES= cmake compiler:c++11-lang desktop-file-utils qt:5 \
shared-mime-info tar:xz
USE_QT= buildtools_build concurrent core dbus gui linguisttools network \
- qmake_build testlib widgets
+ qmake_build svg testlib widgets
USE_XORG= x11
USE_LDCONFIG= yes
@@ -37,23 +37,23 @@ CMAKE_ARGS+= -DCMAKE_INSTALL_MANDIR=${PREFIX}/man
CONFLICTS_INSTALL= keepassx-0.* keepassx2-* keepassx-*
-OPTIONS_DEFINE= AUTOTYPE BROWSER HTTP NETWORKING YUBIKEY SSHAGENT TEST
-OPTIONS_DEFAULT= AUTOTYPE BROWSER HTTP NETWORKING SSHAGENT
+OPTIONS_DEFINE= AUTOTYPE BROWSER KEESHARE NETWORKING YUBIKEY SSHAGENT TEST
+OPTIONS_DEFAULT= AUTOTYPE BROWSER KEESHARE NETWORKING SSHAGENT
OPTIONS_SUB= yes
AUTOTYPE_CMAKE_BOOL= WITH_XC_AUTOTYPE
AUTOTYPE_DESC= Auto-type passwords in input fields
-AUTOTYPE_USES= qt:5
AUTOTYPE_USE= QT=x11extras XORG=xi,xtst
BROWSER_CMAKE_BOOL= WITH_XC_BROWSER
BROWSER_DESC= Browser integration with KeePassXC-Browser
BROWSER_LIB_DEPENDS= libsodium.so:security/libsodium
-# Legacy/Deprecated.
-HTTP_CMAKE_BOOL= WITH_XC_HTTP
-HTTP_DESC= KeePassHTTP support for ChromeIPass and PassIFox
+KEESHARE_CMAKE_BOOL= WITH_XC_KEESHARE WITH_XC_KEESHARE_SECURE
+KEESHARE_DESC= Sharing integration with KeeShare
+KEESHARE_LIB_DEPENDS= libquazip5.so:archivers/quazip
+# Legacy/Deprecated.
NETWORKING_CMAKE_BOOL= WITH_XC_NETWORKING
NETWORKING_DESC= Networking support (e.g. for downloading website icons)
@@ -72,7 +72,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|Q_OS_LINUX|Q_OS_UNIX|g' \
${WRKSRC}/src/browser/HostInstaller.cpp
- @${REINPLACE_CMD} -e 's|u_int|__uint|g' \
- ${WRKSRC}/src/sshagent/blf.h
-
.include <bsd.port.mk>
diff --git a/security/keepassxc/distinfo b/security/keepassxc/distinfo
index f8e490b230e4..09c2f71d113c 100644
--- a/security/keepassxc/distinfo
+++ b/security/keepassxc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1535381169
-SHA256 (keepassxc-2.3.4.tar.xz) = 0c24a78895185b9b6b098f08a15b332c600f80aa570d608940fcc2a38e02780a
-SIZE (keepassxc-2.3.4.tar.xz) = 4137176
+TIMESTAMP = 1553292671
+SHA256 (keepassxc-2.4.0.tar.xz) = 081ff1a34da8e0e8db951b5d70824d7a2b3d299ed4ae54e6ddc1e3ac176b95a8
+SIZE (keepassxc-2.4.0.tar.xz) = 3252104
diff --git a/security/keepassxc/files/patch-CMakeLists.txt b/security/keepassxc/files/patch-CMakeLists.txt
index 69ac5c68079d..ec948aa222e0 100644
--- a/security/keepassxc/files/patch-CMakeLists.txt
+++ b/security/keepassxc/files/patch-CMakeLists.txt
@@ -1,7 +1,7 @@
---- CMakeLists.txt.orig 2018-04-01 08:03:48 UTC
+--- CMakeLists.txt.orig 2019-03-19 22:59:14 UTC
+++ CMakeLists.txt
-@@ -166,7 +166,7 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
- add_gcc_compiler_flags("-Werror")
+@@ -192,7 +192,7 @@ if(CMAKE_BUILD_TYPE STREQUAL "Debug")
+ add_gcc_compiler_flags("-Werror")
endif()
-if((CMAKE_COMPILER_IS_GNUCXX AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER 4.8.999) OR CMAKE_COMPILER_IS_CLANGXX)
diff --git a/security/keepassxc/files/patch-src_gui_entry_EditEntryWidget.cpp b/security/keepassxc/files/patch-src_gui_entry_EditEntryWidget.cpp
deleted file mode 100644
index 3b107dc23dbc..000000000000
--- a/security/keepassxc/files/patch-src_gui_entry_EditEntryWidget.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix build with Qt 5.11
-Fixed upstream: https://github.com/keepassxreboot/keepassxc/commit/3bbc6ac
-
---- src/gui/entry/EditEntryWidget.cpp.orig 2018-08-31 04:04:41 UTC
-+++ src/gui/entry/EditEntryWidget.cpp
-@@ -29,6 +29,7 @@
- #include <QMenu>
- #include <QSortFilterProxyModel>
- #include <QTemporaryFile>
-+#include <QButtonGroup>
- #include <QMimeData>
- #include <QEvent>
- #include <QColorDialog>
diff --git a/security/keepassxc/pkg-descr b/security/keepassxc/pkg-descr
index 01c4ba7d7635..7fe5826aa9e2 100644
--- a/security/keepassxc/pkg-descr
+++ b/security/keepassxc/pkg-descr
@@ -5,26 +5,20 @@ open-source password manager.
Main Features
- * Secure storage of passwords and other private data with AES, Twofish or
- ChaCha20 encryption
- * Cross-platform, runs on Linux, Windows and macOS without modifications
+ * Secure storage with AES, Twofish or ChaCha20 encryption
* File format compatibility with KeePass2, KeePassX, MacPass, KeeWeb and many
others (KDBX 3.1 and 4.0)
* SSH Agent integration
- * Auto-Type on all supported platforms for automagically filling in login
- forms
+ * Passwords synchronization using KeeShare
+ * Auto-Type for automagically filling in login forms
* Key file and YubiKey challenge-response support for additional security
* TOTP generation (including Steam Guard)
* CSV import from other password managers (e.g., LastPass)
* Command line interface
- * Stand-alone password and passphrase generator
- * Password strength meter
* Custom icons for database entries and download of website favicons
* Database merge functionality
* Automatic reload when the database was changed externally
* Browser integration with KeePassXC-Browser for Google Chrome, Chromium,
Vivaldi, and Mozilla Firefox.
- * (Legacy) KeePassHTTP support for use with KeePassHTTP-Connector available
- for Mozilla Firefox and Google Chrome, and passafari for Safari.
WWW: https://keepassxc.org
diff --git a/security/keepassxc/pkg-plist b/security/keepassxc/pkg-plist
index ef5ab56f9474..a733d90758ca 100644
--- a/security/keepassxc/pkg-plist
+++ b/security/keepassxc/pkg-plist
@@ -37,15 +37,16 @@ share/icons/hicolor/64x64/apps/keepassxc-locked.png
share/icons/hicolor/64x64/apps/keepassxc-unlocked.png
share/icons/hicolor/64x64/apps/keepassxc.png
share/icons/hicolor/64x64/mimetypes/application-x-keepassxc.png
-share/icons/hicolor/scalable/apps/keepassxc-dark.svgz
-share/icons/hicolor/scalable/apps/keepassxc-locked.svgz
-share/icons/hicolor/scalable/apps/keepassxc-unlocked.svgz
-share/icons/hicolor/scalable/apps/keepassxc.svgz
-share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
+share/icons/hicolor/scalable/apps/keepassxc-dark.svg
+share/icons/hicolor/scalable/apps/keepassxc-locked.svg
+share/icons/hicolor/scalable/apps/keepassxc-unlocked.svg
+share/icons/hicolor/scalable/apps/keepassxc.svg
+share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svg
%%DATADIR%%/icons/application/128x128/apps/keepassxc-dark.png
%%DATADIR%%/icons/application/128x128/apps/keepassxc-locked.png
%%DATADIR%%/icons/application/128x128/apps/keepassxc-unlocked.png
%%DATADIR%%/icons/application/128x128/apps/keepassxc.png
+%%DATADIR%%/icons/application/128x128/apps/preferences-system-network-sharing.png
%%DATADIR%%/icons/application/128x128/mimetypes/application-x-keepassxc.png
%%DATADIR%%/icons/application/16x16/actions/application-exit.png
%%DATADIR%%/icons/application/16x16/actions/auto-type.png
@@ -64,6 +65,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/icons/application/16x16/actions/entry-delete.png
%%DATADIR%%/icons/application/16x16/actions/entry-edit.png
%%DATADIR%%/icons/application/16x16/actions/entry-new.png
+%%DATADIR%%/icons/application/16x16/actions/favicon-download.png
%%DATADIR%%/icons/application/16x16/actions/group-delete.png
%%DATADIR%%/icons/application/16x16/actions/group-edit.png
%%DATADIR%%/icons/application/16x16/actions/group-empty-trash.png
@@ -76,6 +78,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/icons/application/16x16/actions/password-generator.png
%%DATADIR%%/icons/application/16x16/actions/password-show-off.png
%%DATADIR%%/icons/application/16x16/actions/password-show-on.png
+%%DATADIR%%/icons/application/16x16/actions/system-help.png
%%DATADIR%%/icons/application/16x16/actions/system-search.png
%%DATADIR%%/icons/application/16x16/actions/url-copy.png
%%DATADIR%%/icons/application/16x16/actions/username-copy.png
@@ -97,6 +100,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/icons/application/22x22/actions/entry-delete.png
%%DATADIR%%/icons/application/22x22/actions/entry-edit.png
%%DATADIR%%/icons/application/22x22/actions/entry-new.png
+%%DATADIR%%/icons/application/22x22/actions/favicon-download.png
%%DATADIR%%/icons/application/22x22/actions/group-empty-trash.png
%%DATADIR%%/icons/application/22x22/actions/help-about.png
%%DATADIR%%/icons/application/22x22/actions/message-close.png
@@ -104,6 +108,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/icons/application/22x22/actions/password-copy.png
%%DATADIR%%/icons/application/22x22/actions/password-generate.png
%%DATADIR%%/icons/application/22x22/actions/password-generator.png
+%%DATADIR%%/icons/application/22x22/actions/system-help.png
%%DATADIR%%/icons/application/22x22/actions/system-search.png
%%DATADIR%%/icons/application/22x22/actions/url-copy.png
%%DATADIR%%/icons/application/22x22/actions/username-copy.png
@@ -139,6 +144,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/icons/application/32x32/actions/entry-delete.png
%%DATADIR%%/icons/application/32x32/actions/entry-edit.png
%%DATADIR%%/icons/application/32x32/actions/entry-new.png
+%%DATADIR%%/icons/application/32x32/actions/favicon-download.png
%%DATADIR%%/icons/application/32x32/actions/group-empty-trash.png
%%DATADIR%%/icons/application/32x32/actions/help-about.png
%%DATADIR%%/icons/application/32x32/actions/key-enter.png
@@ -148,6 +154,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/icons/application/32x32/actions/password-generator.png
%%DATADIR%%/icons/application/32x32/actions/password-show-off.png
%%DATADIR%%/icons/application/32x32/actions/password-show-on.png
+%%DATADIR%%/icons/application/32x32/actions/system-help.png
%%DATADIR%%/icons/application/32x32/actions/system-search.png
%%DATADIR%%/icons/application/32x32/actions/url-copy.png
%%DATADIR%%/icons/application/32x32/actions/username-copy.png
@@ -171,11 +178,11 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/icons/application/64x64/apps/keepassxc-unlocked.png
%%DATADIR%%/icons/application/64x64/apps/keepassxc.png
%%DATADIR%%/icons/application/64x64/mimetypes/application-x-keepassxc.png
-%%DATADIR%%/icons/application/scalable/apps/keepassxc-dark.svgz
-%%DATADIR%%/icons/application/scalable/apps/keepassxc-locked.svgz
-%%DATADIR%%/icons/application/scalable/apps/keepassxc-unlocked.svgz
-%%DATADIR%%/icons/application/scalable/apps/keepassxc.svgz
-%%DATADIR%%/icons/application/scalable/mimetypes/application-x-keepassxc.svgz
+%%DATADIR%%/icons/application/scalable/apps/keepassxc-dark.svg
+%%DATADIR%%/icons/application/scalable/apps/keepassxc-locked.svg
+%%DATADIR%%/icons/application/scalable/apps/keepassxc-unlocked.svg
+%%DATADIR%%/icons/application/scalable/apps/keepassxc.svg
+%%DATADIR%%/icons/application/scalable/mimetypes/application-x-keepassxc.svg
%%DATADIR%%/icons/database/C00_Password.png
%%DATADIR%%/icons/database/C01_Package_Network.png
%%DATADIR%%/icons/database/C02_MessageBox_Warning.png
@@ -258,16 +265,22 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/translations/keepassx_eu.qm
%%DATADIR%%/translations/keepassx_fi.qm
%%DATADIR%%/translations/keepassx_fr.qm
+%%DATADIR%%/translations/keepassx_he.qm
+%%DATADIR%%/translations/keepassx_hr_HR.qm
%%DATADIR%%/translations/keepassx_hu.qm
%%DATADIR%%/translations/keepassx_id.qm
+%%DATADIR%%/translations/keepassx_is_IS.qm
%%DATADIR%%/translations/keepassx_it.qm
%%DATADIR%%/translations/keepassx_ja.qm
%%DATADIR%%/translations/keepassx_kk.qm
%%DATADIR%%/translations/keepassx_ko.qm
+%%DATADIR%%/translations/keepassx_la.qm
%%DATADIR%%/translations/keepassx_lt.qm
+%%DATADIR%%/translations/keepassx_lv.qm
%%DATADIR%%/translations/keepassx_nb.qm
%%DATADIR%%/translations/keepassx_nl_NL.qm
%%DATADIR%%/translations/keepassx_pl.qm
+%%DATADIR%%/translations/keepassx_pt.qm
%%DATADIR%%/translations/keepassx_pt_BR.qm
%%DATADIR%%/translations/keepassx_pt_PT.qm
%%DATADIR%%/translations/keepassx_ro.qm
@@ -281,6 +294,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-keepassxc.svgz
%%DATADIR%%/translations/keepassx_uk.qm
%%DATADIR%%/translations/keepassx_zh_CN.qm
%%DATADIR%%/translations/keepassx_zh_TW.qm
+%%DATADIR%%/wizard/background-pixmap.png
%%DATADIR%%/wordlists/eff_large.wordlist
share/metainfo/org.keepassxc.KeePassXC.appdata.xml
share/mime/packages/keepassxc.xml