aboutsummaryrefslogtreecommitdiff
path: root/security/knocker/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-29 23:53:40 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-29 23:53:40 +0000
commit492002c8fb8b486cc02ad52f35f4dddb40abdb9d (patch)
treef3bf047f87f462aaa2843bf4c4809ba635986f19 /security/knocker/Makefile
parent71ea9495ad4130fe1ba627c229f7db7721302b6d (diff)
downloadports-492002c8fb8b486cc02ad52f35f4dddb40abdb9d.tar.gz
ports-492002c8fb8b486cc02ad52f35f4dddb40abdb9d.zip
New port knocker version 0.3.0, A simple and easy to use TCP only
port scanner (Console version) PR: 29108 Submitted by: Patrick Li <pat@databits.net>
Notes
Notes: svn path=/head/; revision=45596
Diffstat (limited to 'security/knocker/Makefile')
-rw-r--r--security/knocker/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/knocker/Makefile b/security/knocker/Makefile
new file mode 100644
index 000000000000..492fdc225ae4
--- /dev/null
+++ b/security/knocker/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: knocker
+# Date created: Tue Jul 10 01:42:52 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= knocker
+PORTVERSION= 0.3.0
+CATEGORIES= security net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= pat@databits.net
+
+GNU_CONFIGURE= yes
+
+MAN1= ${PORTNAME}.1
+
+pre-patch:
+ @${PERL} -pi.orig -e 's|-lpthread|${PTHREAD_LIBS}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>