aboutsummaryrefslogtreecommitdiff
path: root/security/kpcli/Makefile
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-05-01 01:42:38 +0000
commit4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448 (patch)
tree7d2afea24bed5487a0bed70a4ce863d70ee3d368 /security/kpcli/Makefile
parentb3b7323d8ef412f19e96f476f048c4f46aa36bab (diff)
downloadports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.tar.gz
ports-4ca54cc2f2b045a73d2db7ca2fe2d76bb8847448.zip
STAGE support, and general cleanups. Some of the changes are a
bit more aggressive, but at this point, if I'm staging your port, you've likely stopped caring what's done to it.
Notes
Notes: svn path=/head/; revision=352710
Diffstat (limited to 'security/kpcli/Makefile')
-rw-r--r--security/kpcli/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/security/kpcli/Makefile b/security/kpcli/Makefile
index 51fc647cd0c5..d65ab8c20857 100644
--- a/security/kpcli/Makefile
+++ b/security/kpcli/Makefile
@@ -24,21 +24,17 @@ RUN_DEPENDS= p5-Crypt-Rijndael>=1.08:${PORTSDIR}/security/p5-Crypt-Rijndael \
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
-MAN1= ${PORTNAME}.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/kpcli
+PLIST_FILES= bin/kpcli man/man1/${PORTNAME}.1.gz
-NO_STAGE= yes
do-extract:
@${MKDIR} ${WRKSRC}
- @${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}.pl ${WRKSRC}/${PORTNAME}
+ ${CP} ${DISTDIR}/${PORTNAME}-${PORTVERSION}.pl ${WRKSRC}/${PORTNAME}
do-build:
${LOCALBASE}/bin/pod2man ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
- ${GZIP_CMD} ${WRKSRC}/${PORTNAME}.1
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1.gz ${MAN1PREFIX}/man/man1/
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>