aboutsummaryrefslogtreecommitdiff
path: root/security/libssh
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /security/libssh
parent4706739618b79681811e5b336a54032908638160 (diff)
downloadports-fb3520254ab73be0aad04c3a63b781750cf26b5b.tar.gz
ports-fb3520254ab73be0aad04c3a63b781750cf26b5b.zip
- Convert to OptionsNG
- Trim header Reviewed by: beat, bapt, kwm
Notes
Notes: svn path=/head/; revision=313460
Diffstat (limited to 'security/libssh')
-rw-r--r--security/libssh/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/security/libssh/Makefile b/security/libssh/Makefile
index 1f28565cdeee..e492f5dd923b 100644
--- a/security/libssh/Makefile
+++ b/security/libssh/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libssh
-# Date created: 12 April 2009
-# Whom: Alexander Logvinov <ports@logvinov.com>
-#
+# Created by: Alexander Logvinov <ports@logvinov.com>
# $FreeBSD$
-#
PORTNAME= libssh
PORTVERSION= 0.5.2
@@ -14,8 +10,9 @@ MASTER_SITES= http://www.libssh.org/files/0.5/ \
MAINTAINER= fluffy@FreeBSD.org
COMMENT= A library implementing the SSH1 and SSH2 protocol
-OPTIONS= GCRYPT "Build with libgcrypt" off \
- SSH1 "Build with SSH1 support" off
+OPTIONS_DEFINE= GCRYPT SSH1
+GCRYPT_DESC= Build with libgcrypt
+SSH1_DESC= Build with SSH1 support
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
@@ -31,14 +28,14 @@ LICENSE_FILE= ${WRKSRC}/COPYING
.include <bsd.port.options.mk>
-.if defined(WITH_GCRYPT)
+.if ${PORT_OPTIONS:MGCRYPT}
LIB_DEPENDS+= gcrypt.18:${PORTSDIR}/security/libgcrypt
CMAKE_ARGS+= -DWITH_GCRYPT:BOOL=ON
.else
USE_OPENSSL= yes
.endif
-.if defined(WITH_SSH1)
+.if ${PORT_OPTIONS:MSSH1}
CMAKE_ARGS+= -DWITH_SSH1:BOOL=ON
PLIST_SUB+= SSH1=""
.else