aboutsummaryrefslogtreecommitdiff
path: root/security/libzrtpcppcore
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /security/libzrtpcppcore
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'security/libzrtpcppcore')
-rw-r--r--security/libzrtpcppcore/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/security/libzrtpcppcore/Makefile b/security/libzrtpcppcore/Makefile
index f5a9d4f1b382..40cf58c17065 100644
--- a/security/libzrtpcppcore/Makefile
+++ b/security/libzrtpcppcore/Makefile
@@ -16,7 +16,7 @@ USE_GITHUB= yes
GH_ACCOUNT= wernerd
GH_PROJECT= ZRTPCPP
-USES= cmake:outsource compiler:c++11-lib
+USES= cmake:outsource,noninja compiler:c++11-lib
USE_CXXSTD= c++11
CMAKE_ARGS= -DCORE_LIB:BOOL=ON
USE_LDCONFIG= yes