aboutsummaryrefslogtreecommitdiff
path: root/security/linux-c6-openssl
diff options
context:
space:
mode:
authorJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
committerJohannes Jost Meixner <xmj@FreeBSD.org>2014-09-22 10:40:00 +0000
commit05317facbedf1ed4566b56f4e09e6e4a49fc3f38 (patch)
treef0614b64c20d137667eadfbdc5663150937dc6c3 /security/linux-c6-openssl
parentf287925fdbb7ff7ab55ee8aaa28cf756fe49a296 (diff)
downloadports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.tar.gz
ports-05317facbedf1ed4566b56f4e09e6e4a49fc3f38.zip
Update CentOS base to 6.5, add userland ports
The Fedora 10 infrastructure ports have been in use since June 2009 and, while having served a great deed, have become unsupported upstream and hence affected by unfixed security vulnerabilities. In addition to that, many recent Linux binaries need newer libc / stdlibc++ versions. This commit adds the linux-c6- userland as drop-in replacement for the -f10 infrastructure, as well as upgrading the linux_base-c6 port to CentOS 6.5. If you want to switch to linux-c6 ports, please define at /etc/make.conf: OVERRIDE_LINUX_BASE_PORT=c6 OVERRIDE_LINUX_NONBASE_PORTS=c6 Additionally, please add the following line to /etc/sysctl.conf: compat.linux.osrelease=2.6.18 Upgrading procedures are shown in /usr/ports/UPDATING. This work has been inspired by Artyom Mirgorodskiy's post to emulation@ in November 2013, using and extending mav@'s work. It has been tested extensively and most reported issues were already fixed. Please report any additional bug or "features" to the emulation mailing list. Many thanks to: mav@, rene@, allanjude@, netchild@, antoine@, everyone who's filed Issues and Pull requests on GitHub, PR: 186820 Differential Revision: https://reviews.freebsd.org/D793 Reviewed by: allanjude, antoine, bapt, rene Approved by: portmgr (antoine, bapt) Approved by: koobs (mentor) Sponsored by: Perceivon Hosting Inc.
Notes
Notes: svn path=/head/; revision=368845
Diffstat (limited to 'security/linux-c6-openssl')
-rw-r--r--security/linux-c6-openssl/Makefile24
-rw-r--r--security/linux-c6-openssl/distinfo.i6864
-rw-r--r--security/linux-c6-openssl/pkg-plist112
3 files changed, 140 insertions, 0 deletions
diff --git a/security/linux-c6-openssl/Makefile b/security/linux-c6-openssl/Makefile
new file mode 100644
index 000000000000..09efe9ae41a7
--- /dev/null
+++ b/security/linux-c6-openssl/Makefile
@@ -0,0 +1,24 @@
+# Created by: Artyom Mirgorodskiy <artyom.mirgorodsky@gmail.com>
+# $FreeBSD$
+
+PORTNAME= openssl
+PORTVERSION= 1.0.1e
+CATEGORIES= security linux
+MASTER_SITES= CENTOS_LINUX_UPDATES
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= OpenSSL toolkit (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-openssl-[0-9]* linux-f8-openssl-[0-9]* linux-f10-openssl-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+USE_LINUX= c6
+USE_LINUX_RPM= yes
+RPMVERSION= 16.el6_5.7
+BRANDELF_FILES= usr/bin/openssl
+USE_LDCONFIG= yes
+
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>
diff --git a/security/linux-c6-openssl/distinfo.i686 b/security/linux-c6-openssl/distinfo.i686
new file mode 100644
index 000000000000..a37712624322
--- /dev/null
+++ b/security/linux-c6-openssl/distinfo.i686
@@ -0,0 +1,4 @@
+SHA256 (rpm/i686/centos/6.5/openssl-1.0.1e-16.el6_5.7.i686.rpm) = 6ceff4bad2608484b9b9ab74b8e9047b593b6b7a6ca5ba3cc16db7d8b447f1d8
+SIZE (rpm/i686/centos/6.5/openssl-1.0.1e-16.el6_5.7.i686.rpm) = 1573848
+SHA256 (rpm/i686/centos/6.5/openssl-1.0.1e-16.el6_5.7.src.rpm) = 3a08cda99f54b97c027ed32758e7b1ddcff635be5c3737c1e9084321561a015d
+SIZE (rpm/i686/centos/6.5/openssl-1.0.1e-16.el6_5.7.src.rpm) = 3121145
diff --git a/security/linux-c6-openssl/pkg-plist b/security/linux-c6-openssl/pkg-plist
new file mode 100644
index 000000000000..a02ba11d42da
--- /dev/null
+++ b/security/linux-c6-openssl/pkg-plist
@@ -0,0 +1,112 @@
+@comment file listing
+etc/pki/tls/certs/Makefile
+etc/pki/tls/certs/make-dummy-cert
+etc/pki/tls/certs/renew-dummy-cert
+etc/pki/tls/misc/CA
+etc/pki/tls/misc/c_hash
+etc/pki/tls/misc/c_info
+etc/pki/tls/misc/c_issuer
+etc/pki/tls/misc/c_name
+etc/pki/tls/openssl.cnf
+usr/lib/libcrypto.so.%%PORTVERSION%%
+usr/lib/libcrypto.so.10
+usr/lib/libssl.so.%%PORTVERSION%%
+usr/lib/libssl.so.10
+usr/lib/.libcrypto.so.%%PORTVERSION%%.hmac
+usr/lib/.libcrypto.so.10.hmac
+usr/lib/.libssl.so.%%PORTVERSION%%.hmac
+usr/lib/.libssl.so.10.hmac
+usr/bin/openssl
+usr/lib/openssl/engines/lib4758cca.so
+usr/lib/openssl/engines/libaep.so
+usr/lib/openssl/engines/libatalla.so
+usr/lib/openssl/engines/libcapi.so
+usr/lib/openssl/engines/libchil.so
+usr/lib/openssl/engines/libcswift.so
+usr/lib/openssl/engines/libgmp.so
+usr/lib/openssl/engines/libnuron.so
+usr/lib/openssl/engines/libpadlock.so
+usr/lib/openssl/engines/libsureware.so
+usr/lib/openssl/engines/libubsec.so
+usr/share/doc/openssl-%%PORTVERSION%%/CHANGES
+usr/share/doc/openssl-%%PORTVERSION%%/FAQ
+usr/share/doc/openssl-%%PORTVERSION%%/INSTALL
+usr/share/doc/openssl-%%PORTVERSION%%/LICENSE
+usr/share/doc/openssl-%%PORTVERSION%%/NEWS
+usr/share/doc/openssl-%%PORTVERSION%%/README
+usr/share/doc/openssl-%%PORTVERSION%%/README.FIPS
+usr/share/doc/openssl-%%PORTVERSION%%/c-indentation.el
+usr/share/doc/openssl-%%PORTVERSION%%/openssl.txt
+usr/share/doc/openssl-%%PORTVERSION%%/openssl_button.gif
+usr/share/doc/openssl-%%PORTVERSION%%/openssl_button.html
+usr/share/doc/openssl-%%PORTVERSION%%/ssleay.txt
+usr/share/man/man1/asn1parse.1ssl.gz
+usr/share/man/man1/ca.1ssl.gz
+usr/share/man/man1/ciphers.1ssl.gz
+usr/share/man/man1/crl.1ssl.gz
+usr/share/man/man1/cms.1ssl.gz
+usr/share/man/man1/genpkey.1ssl.gz
+usr/share/man/man1/pkey.1ssl.gz
+usr/share/man/man1/pkeyparam.1ssl.gz
+usr/share/man/man1/pkeyutl.1ssl.gz
+usr/share/man/man1/ts.1ssl.gz
+usr/share/man/man1/tsget.1ssl.gz
+usr/share/man/man1/crl2pkcs7.1ssl.gz
+usr/share/man/man1/dgst.1ssl.gz
+usr/share/man/man1/dhparam.1ssl.gz
+usr/share/man/man1/dsa.1ssl.gz
+usr/share/man/man1/dsaparam.1ssl.gz
+usr/share/man/man1/ec.1ssl.gz
+usr/share/man/man1/ecparam.1ssl.gz
+usr/share/man/man1/enc.1ssl.gz
+usr/share/man/man1/errstr.1ssl.gz
+usr/share/man/man1/gendsa.1ssl.gz
+usr/share/man/man1/genrsa.1ssl.gz
+usr/share/man/man1/md2.1ssl.gz
+usr/share/man/man1/md4.1ssl.gz
+usr/share/man/man1/md5.1ssl.gz
+usr/share/man/man1/mdc2.1ssl.gz
+usr/share/man/man1/nseq.1ssl.gz
+usr/share/man/man1/ocsp.1ssl.gz
+usr/share/man/man1/openssl.1ssl.gz
+usr/share/man/man1/pkcs12.1ssl.gz
+usr/share/man/man1/pkcs7.1ssl.gz
+usr/share/man/man1/pkcs8.1ssl.gz
+usr/share/man/man1/req.1ssl.gz
+usr/share/man/man1/ripemd160.1ssl.gz
+usr/share/man/man1/rsa.1ssl.gz
+usr/share/man/man1/rsautl.1ssl.gz
+usr/share/man/man1/s_client.1ssl.gz
+usr/share/man/man1/s_server.1ssl.gz
+usr/share/man/man1/s_time.1ssl.gz
+usr/share/man/man1/sess_id.1ssl.gz
+usr/share/man/man1/sha.1ssl.gz
+usr/share/man/man1/sha1.1ssl.gz
+usr/share/man/man1/smime.1ssl.gz
+usr/share/man/man1/speed.1ssl.gz
+usr/share/man/man1/spkac.1ssl.gz
+usr/share/man/man1/sslpasswd.1ssl.gz
+usr/share/man/man1/sslrand.1ssl.gz
+usr/share/man/man1/verify.1ssl.gz
+usr/share/man/man1/version.1ssl.gz
+usr/share/man/man1/x509.1ssl.gz
+usr/share/man/man5/config.5ssl.gz
+usr/share/man/man5/openssl.cnf.5ssl.gz
+usr/share/man/man5/x509v3_config.5ssl.gz
+usr/share/man/man7/des_modes.7ssl.gz
+@comment deal with empty directories installed by the port
+@exec /bin/mkdir -p %D/etc/pki/CA/private
+@dirrmtry etc/pki/CA/private
+@exec /bin/mkdir -p %D/etc/pki/tls/private
+@dirrmtry etc/pki/tls/private
+@comment non-empty directory listing in revers order
+@dirrm usr/share/doc/openssl-%%PORTVERSION%%
+@dirrm usr/lib/openssl/engines
+@dirrm usr/lib/openssl
+@dirrm etc/pki/tls/misc
+@dirrm etc/pki/tls/certs
+@dirrm etc/pki/tls
+@dirrm etc/pki/CA/certs
+@dirrm etc/pki/CA/crl
+@dirrm etc/pki/CA/newcerts
+@dirrm etc/pki/CA