aboutsummaryrefslogtreecommitdiff
path: root/security/linux-c6-openssl
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-09-05 19:23:42 +0000
commit82a87de90c337aae160ac254606dad78d0d78d11 (patch)
tree516db145d6cf5fd4d2666f811272aad577272ac5 /security/linux-c6-openssl
parentf22162b04be45bf28d125c67ee0a841fb1ae4b55 (diff)
downloadports-82a87de90c337aae160ac254606dad78d0d78d11.tar.gz
ports-82a87de90c337aae160ac254606dad78d0d78d11.zip
- Replace Mk/bsd.linux-apps.mk and Mk/bsd.linux-rpm.mk with
Mk/Uses/linux.mk. - Replace USE_LINUX=yes with USES+=linux and USE_LINUX=(.*) with USES+=linux:\1 in all ports. - Replace USE_LINUX_APPS with USE_LINUX in all ports. - Use INSTALL_SCRIPT instead of INSTALL_PROGRAM to install scripts in some ports. - When USE_LINUX_RPM is defined, simplify the way DISTFILES and EXTRACT_ONLY are defined. - Remove BRANDELF_DIRS and BRANDELF_FILES handling. In the very rare cases that it is still necessary ports can run ${BRANDELF} from post-patch. - Remove AUTOMATIC_PLIST handling. Only one port used it. - Fix Linux MASTER_SITES. - Replace OVERRIDE_LINUX_BASE_PORT and OVERRIDE_LINUX_NONBASE_PORTS with default versions framework. - bsd.port.mk: - Move Linux related bits to Uses/linux.mk, except USE_LINUX_PREFIX. - Put USE_LINUX_PREFIX handling after USES processing. - Define DOCSDIR, DATADIR, etc. after handling USE_LINUX_PREFIX so it can give these variables a different default value. - When a package needs to run Linux ldconfig check before installation if Linux support is enabled. - emulators/linux_base-*: - Use USES=linux and remove duplication. - Remove files/lp. FreeBSD or CUPS lp(1) should work. - Remove files/yp.conf. No longer seems to be used. - Remove pkg-deinstall and move pkg-install into pkg-plist. - Update pkg-descr and pkg-message. - Fix handling of ldconfig cache in pkg-plist. - devel/fb-adb: Use a Linux shell to run a Linux script but patch the script to use FreeBSD mkdir so mkdir -p $path creates $path and not /compat/linux/$path. PR: 211645 Exp-run by: antoine Approved by: portmgr (antoine)
Notes
Notes: svn path=/head/; revision=421387
Diffstat (limited to 'security/linux-c6-openssl')
-rw-r--r--security/linux-c6-openssl/Makefile5
-rw-r--r--security/linux-c6-openssl/pkg-plist.i38625
-rw-r--r--security/linux-c6-openssl/pkg-plist.x86_6424
3 files changed, 25 insertions, 29 deletions
diff --git a/security/linux-c6-openssl/Makefile b/security/linux-c6-openssl/Makefile
index e60fe6857719..d5c8363fa866 100644
--- a/security/linux-c6-openssl/Makefile
+++ b/security/linux-c6-openssl/Makefile
@@ -5,18 +5,15 @@ PORTNAME= openssl
PORTVERSION= 1.0.1e
PORTREVISION= 10
CATEGORIES= security linux
-MASTER_SITES= CENTOS_LINUX CENTOS_LINUX_UPDATES
MAINTAINER= emulation@FreeBSD.org
COMMENT= OpenSSL toolkit (Linux CentOS ${LINUX_DIST_VER})
CONFLICTS= linux-openssl-[0-9]* linux-f8-openssl-[0-9]* linux-f10-openssl-[0-9]*
-ONLY_FOR_ARCHS= i386 amd64
-USE_LINUX= c6
+USES= linux:c6
USE_LINUX_RPM= yes
RPMVERSION= 48.el6_8.1
-BRANDELF_FILES= usr/bin/openssl
USE_LDCONFIG= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
diff --git a/security/linux-c6-openssl/pkg-plist.i386 b/security/linux-c6-openssl/pkg-plist.i386
index dd9a2b7ae41c..8af38af21c68 100644
--- a/security/linux-c6-openssl/pkg-plist.i386
+++ b/security/linux-c6-openssl/pkg-plist.i386
@@ -1,4 +1,3 @@
-@comment file listing
etc/pki/tls/certs/Makefile
etc/pki/tls/certs/make-dummy-cert
etc/pki/tls/certs/renew-dummy-cert
@@ -28,18 +27,18 @@ usr/lib/openssl/engines/libnuron.so
usr/lib/openssl/engines/libpadlock.so
usr/lib/openssl/engines/libsureware.so
usr/lib/openssl/engines/libubsec.so
-usr/share/doc/openssl-%%PORTVERSION%%/CHANGES
-usr/share/doc/openssl-%%PORTVERSION%%/FAQ
-usr/share/doc/openssl-%%PORTVERSION%%/INSTALL
-usr/share/doc/openssl-%%PORTVERSION%%/LICENSE
-usr/share/doc/openssl-%%PORTVERSION%%/NEWS
-usr/share/doc/openssl-%%PORTVERSION%%/README
-usr/share/doc/openssl-%%PORTVERSION%%/README.FIPS
-usr/share/doc/openssl-%%PORTVERSION%%/c-indentation.el
-usr/share/doc/openssl-%%PORTVERSION%%/openssl.txt
-usr/share/doc/openssl-%%PORTVERSION%%/openssl_button.gif
-usr/share/doc/openssl-%%PORTVERSION%%/openssl_button.html
-usr/share/doc/openssl-%%PORTVERSION%%/ssleay.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.FIPS
+%%PORTDOCS%%%%DOCSDIR%%/c-indentation.el
+%%PORTDOCS%%%%DOCSDIR%%/openssl.txt
+%%PORTDOCS%%%%DOCSDIR%%/openssl_button.gif
+%%PORTDOCS%%%%DOCSDIR%%/openssl_button.html
+%%PORTDOCS%%%%DOCSDIR%%/ssleay.txt
usr/share/man/man1/asn1parse.1ssl.gz
usr/share/man/man1/ca.1ssl.gz
usr/share/man/man1/ciphers.1ssl.gz
diff --git a/security/linux-c6-openssl/pkg-plist.x86_64 b/security/linux-c6-openssl/pkg-plist.x86_64
index 6d479cfa8983..f9bbd54019d2 100644
--- a/security/linux-c6-openssl/pkg-plist.x86_64
+++ b/security/linux-c6-openssl/pkg-plist.x86_64
@@ -46,18 +46,18 @@ usr/lib64/openssl/engines/libnuron.so
usr/lib64/openssl/engines/libpadlock.so
usr/lib64/openssl/engines/libsureware.so
usr/lib64/openssl/engines/libubsec.so
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/CHANGES
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/FAQ
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/INSTALL
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/LICENSE
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/NEWS
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/README
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/README.FIPS
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/c-indentation.el
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/openssl.txt
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/openssl_button.gif
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/openssl_button.html
-%%PORTDOCS%%usr/%%DOCSDIR%%-%%PORTVERSION%%/ssleay.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.FIPS
+%%PORTDOCS%%%%DOCSDIR%%/c-indentation.el
+%%PORTDOCS%%%%DOCSDIR%%/openssl.txt
+%%PORTDOCS%%%%DOCSDIR%%/openssl_button.gif
+%%PORTDOCS%%%%DOCSDIR%%/openssl_button.html
+%%PORTDOCS%%%%DOCSDIR%%/ssleay.txt
usr/share/man/man1/asn1parse.1ssl.gz
usr/share/man/man1/ca.1ssl.gz
usr/share/man/man1/ciphers.1ssl.gz