aboutsummaryrefslogtreecommitdiff
path: root/security/linux-c7-libssh2/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-10-19 14:50:26 +0000
commit1675ff649cded4c85d65feb0f4c5cc87010242eb (patch)
tree3e3556f1e26a35be0250e7f749680b9fc30e9c6b /security/linux-c7-libssh2/Makefile
parent4fd1b570a8aec1244c7b8469c29c309a96a46804 (diff)
downloadports-1675ff649cded4c85d65feb0f4c5cc87010242eb.tar.gz
ports-1675ff649cded4c85d65feb0f4c5cc87010242eb.zip
Add Linux CentOS 7 infrastructure ports.
Mk/Uses/linux.mk changes: - Add support for architecture neutral (noarch) distfiles. - Add support for 64-bit only ports: set IGNORE on i386 and don't install 32-bit compat libraries on amd64. Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Differential Revision: https://reviews.freebsd.org/D7886
Notes
Notes: svn path=/head/; revision=424259
Diffstat (limited to 'security/linux-c7-libssh2/Makefile')
-rw-r--r--security/linux-c7-libssh2/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/security/linux-c7-libssh2/Makefile b/security/linux-c7-libssh2/Makefile
new file mode 100644
index 000000000000..d97126d62877
--- /dev/null
+++ b/security/linux-c7-libssh2/Makefile
@@ -0,0 +1,22 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= libssh2
+PORTVERSION= 1.4.3
+CATEGORIES= security linux
+
+MAINTAINER= emulation@FreeBSD.org
+COMMENT= Library implementing the SSH2 protocol (Linux CentOS ${LINUX_DIST_VER})
+
+CONFLICTS= linux-f10-${PORTNAME}-[0-9]* linux-c6-${PORTNAME}-[0-9]*
+
+RPMVERSION= 10.el7
+USES= linux:c7
+USE_LDCONFIG= yes
+USE_LINUX= openssl
+USE_LINUX_RPM= yes
+
+PORTDOCS= AUTHORS COPYING ChangeLog NEWS README
+DESCR= ${.CURDIR}/../${PORTNAME}/pkg-descr
+
+.include <bsd.port.mk>