aboutsummaryrefslogtreecommitdiff
path: root/security/medusa/Makefile
diff options
context:
space:
mode:
authorMichael Osipov <michaelo@FreeBSD.org>2024-02-12 14:31:19 +0000
committerMichael Osipov <michaelo@FreeBSD.org>2024-02-28 15:53:37 +0000
commite83f0a9c84eabcc1307440925cc8d2d6b3dc4566 (patch)
tree121a0608345e64cbf9e4e52f586ce05c305b52c2 /security/medusa/Makefile
parenta1b345c5d37b9bde0f91003e194a51c3f8fc30e9 (diff)
downloadports-e83f0a9c84eabcc1307440925cc8d2d6b3dc4566.tar.gz
ports-e83f0a9c84eabcc1307440925cc8d2d6b3dc4566.zip
*/*: Properly depend on Subversion LTS or latest with WITH_SUBVERSION_VER
When LTS version of Subversion is set in make.conf (WITH_SUBVERSION_VER) depending ports will still depend on latest version (devel/subversion) instead of LTS one (devel/subversion-lts). This will cause dependency conflicts when packages are distributed with Poudriere, namely pkg(8) will report them and fail to install. Make all affected ports properly depend on the right port based on the value set in WITH_SUBVERSION_VER. Approved by: jrm (mentor), otis (mentor), lev (maintainer timeout) Differential Revision: https://reviews.freebsd.org/D43864
Diffstat (limited to 'security/medusa/Makefile')
-rw-r--r--security/medusa/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/security/medusa/Makefile b/security/medusa/Makefile
index 95b28f8a882c..749d363deea6 100644
--- a/security/medusa/Makefile
+++ b/security/medusa/Makefile
@@ -1,6 +1,6 @@
PORTNAME= medusa
PORTVERSION= 2.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://www.foofus.net/~jmk/tools/
@@ -22,7 +22,11 @@ CFLAGS+= -fcommon
OPTIONS_DEFINE= DOCS PGSQL SUBVERSION
OPTIONS_SUB= yes
+.if ${WITH_SUBVERSION_VER:U} == LTS
+SUBVERSION_LIB_DEPENDS= libsvn_client-1.so:devel/subversion-lts
+.else
SUBVERSION_LIB_DEPENDS= libsvn_client-1.so:devel/subversion
+.endif
SUBVERSION_CFLAGS= -I${LOCALBASE}/include/subversion-1 -I${LOCALBASE}/include/apr-1
SUBVERSION_CONFIGURE_OFF= --enable-module-svn=no