aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit/Makefile
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-04-05 11:26:52 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-04-05 11:26:52 +0000
commit1233853a1e9180e61b12877410c2c53394c9b0b7 (patch)
tree732fcd729cdbe12240592a8511f1ebc9dd7cf514 /security/metasploit/Makefile
parent4a1df6cd550622505209ba4459833ddbfc5e09cc (diff)
downloadports-1233853a1e9180e61b12877410c2c53394c9b0b7.tar.gz
ports-1233853a1e9180e61b12877410c2c53394c9b0b7.zip
security/metasploit: Update rubygem-rex-exploitation dependency
While here, reorder some variables. PR: 245047 Submitted by: rl+fbsd@ciphron.de Approved by: tanawts@gmail.com(maintainer, timeout > 1 week)
Notes
Notes: svn path=/head/; revision=530769
Diffstat (limited to 'security/metasploit/Makefile')
-rw-r--r--security/metasploit/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index 9637bd9a4c87..ec712d5fe367 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -62,7 +62,7 @@ RUN_DEPENDS= nmap:security/nmap \
rubygem-rex-bin_tools>=0:security/rubygem-rex-bin_tools \
rubygem-rex-core>=0:security/rubygem-rex-core \
rubygem-rex-encoder>=0:security/rubygem-rex-encoder \
- rubygem-rex-exploitation>=0:security/rubygem-rex-exploitation \
+ rubygem-rex-exploitation>=0.1.22:security/rubygem-rex-exploitation \
rubygem-rex-java>=0:security/rubygem-rex-java \
rubygem-rex-mime>=0:security/rubygem-rex-mime \
rubygem-rex-nop>=0:security/rubygem-rex-nop \
@@ -93,16 +93,6 @@ RUN_DEPENDS= nmap:security/nmap \
rubygem-faye-websocket>=0:www/rubygem-faye-websocket \
rubygem-eventmachine>=0:devel/rubygem-eventmachine
-SCRIPTS= msfconsole msfd msfdb msfrpc msfrpcd msfvenom
-
-USE_GITHUB= yes
-GH_ACCOUNT= rapid7
-GH_PROJECT= metasploit-framework
-
-NO_ARCH= yes
-NO_ARCH_IGNORE= template_x64_bsd.bin template_x86_bsd.bin CVE-2013-2171.bin
-STRIP=
-
USES= python shebangfix
USE_RUBY= yes
SHEBANG_FILES= data/exploits/CVE-2017-17562/build.sh \
@@ -139,6 +129,14 @@ SHEBANG_FILES= data/exploits/CVE-2017-17562/build.sh \
tools/hardware/killerbee_msfrelay.py \
tools/modules/aws-aggregator-userdata.sh
+USE_GITHUB= yes
+GH_ACCOUNT= rapid7
+GH_PROJECT= metasploit-framework
+
+NO_ARCH= yes
+NO_ARCH_IGNORE= template_x64_bsd.bin template_x86_bsd.bin CVE-2013-2171.bin
+STRIP=
+
post-patch:
${REINPLACE_CMD} 's,git ls-files,find . ! -type d | sed "s|^./||", ; \
/rb-readline/d' \
@@ -157,7 +155,7 @@ do-build:
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC} && ${PAX} -rw . ${STAGEDIR}${DATADIR}
-.for f in ${SCRIPTS}
+.for f in msfd msfdb msfrpc msfrpcd msfvenom
${RLN} ${STAGEDIR}${DATADIR}/${f} ${STAGEDIR}${PREFIX}/bin/${f}
.endfor