aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-05 13:32:41 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-05 13:32:41 +0000
commitc227e9a20bb4a5bb245292b8bc88e1c88790002b (patch)
tree99e9ddabd2d533806698fa38bd05bcb9605cf8d9 /security/metasploit/Makefile
parent9eed0649b3ba91a9b98e5ecdae578c8a5573b980 (diff)
downloadports-c227e9a20bb4a5bb245292b8bc88e1c88790002b.tar.gz
ports-c227e9a20bb4a5bb245292b8bc88e1c88790002b.zip
Remove dependency on rb-readline, it works fine without it
Notes
Notes: svn path=/head/; revision=374025
Diffstat (limited to 'security/metasploit/Makefile')
-rw-r--r--security/metasploit/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index 8a6189d66937..aaf21a31ff3d 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -3,6 +3,7 @@
PORTNAME= metasploit
PORTVERSION= 4.10.2
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= GH
@@ -27,7 +28,6 @@ RUN_DEPENDS= nasm:${PORTSDIR}/devel/nasm \
rubygem-pcaprub>=0:${PORTSDIR}/net/rubygem-pcaprub \
rubygem-railties>=3.0.0:${PORTSDIR}/www/rubygem-railties \
rubygem-recog>=1.0:${PORTSDIR}/security/rubygem-recog \
- rubygem-rb-readline>=0:${PORTSDIR}/devel/rubygem-rb-readline \
rubygem-robots>=0:${PORTSDIR}/www/rubygem-robots \
rubygem-rubyzip>=1.1:${PORTSDIR}/archivers/rubygem-rubyzip \
rubygem-sqlite3>=0:${PORTSDIR}/databases/rubygem-sqlite3 \
@@ -57,8 +57,9 @@ DB_RUN_DEPENDS= rubygem-activerecord>=3.0.0:${PORTSDIR}/databases/rubygem-active
.include <bsd.port.options.mk>
post-patch:
- ${REINPLACE_CMD} 's,git ls-files,find . ! -type d ! -ipath "config/*" | sed "s|^./||", ; \
- /packetfu/s/1.1.9/>= 1.1.9/' ${WRKSRC}/metasploit-framework.gemspec
+ ${REINPLACE_CMD} 's,git ls-files,find . ! -type d | sed "s|^./||", ; \
+ /packetfu/s/1.1.9/>= 1.1.9/ ; \
+ /rb-readline/d' ${WRKSRC}/metasploit-framework.gemspec
do-build:
${RM} ${WRKSRC}/Gemfile.lock