aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-31 07:57:48 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-08-31 07:57:48 +0000
commitc75fcc2a6e84bf629aa6e9b5f0d2c66d0c4060c2 (patch)
tree27fa37326fed8ab97856d75a730d565fb8c09b16 /security/metasploit/Makefile
parent7ae477fa32cc83497cad50b0012ee4382183f210 (diff)
downloadports-c75fcc2a6e84bf629aa6e9b5f0d2c66d0c4060c2.tar.gz
ports-c75fcc2a6e84bf629aa6e9b5f0d2c66d0c4060c2.zip
Remove outdated RUBY_VER check
With hat: ruby
Notes
Notes: svn path=/head/; revision=510355
Diffstat (limited to 'security/metasploit/Makefile')
-rw-r--r--security/metasploit/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index f4c436ccc28c..d7b7c385c593 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -51,6 +51,7 @@ RUN_DEPENDS= nmap:security/nmap \
rubygem-sshkey>=0:security/rubygem-sshkey \
rubygem-bit-struct>=0:devel/rubygem-bit-struct \
rubygem-windows_error>=0:devel/rubygem-windows_error \
+ rubygem-xmlrpc>=0:net/rubygem-xmlrpc \
rubygem-pdf-reader>=0:print/rubygem-pdf-reader \
rubygem-ruby-macho>=0:devel/rubygem-ruby-macho \
rubygem-dnsruby>=0:dns/rubygem-dnsruby \
@@ -125,21 +126,12 @@ SHEBANG_FILES= data/exploits/CVE-2017-17562/build.sh \
tools/hardware/killerbee_msfrelay.py \
tools/modules/aws-aggregator-userdata.sh
-.include <bsd.port.pre.mk>
-
-.if ${RUBY_VER} >= 2.4
-RUN_DEPENDS+= rubygem-xmlrpc>=0:net/rubygem-xmlrpc
-.endif
-
post-patch:
${REINPLACE_CMD} 's,git ls-files,find . ! -type d | sed "s|^./||", ; \
/rb-readline/d' \
${WRKSRC}/metasploit-framework.gemspec
${REINPLACE_CMD} "/pg/s|, '0.20.0'||; \
/concurrent-ruby/s|,'1.0.5'||" ${WRKSRC}/metasploit-framework.gemspec
-.if ${RUBY_VER} < 2.4
- ${REINPLACE_CMD} '/xmlrpc/d' ${WRKSRC}/metasploit-framework.gemspec
-.endif
do-build:
${RM} ${WRKSRC}/Gemfile.lock
@@ -160,4 +152,4 @@ post-install:
@${FIND} -ds ${STAGEDIR}${DATADIR} -type d -empty | \
${SED} 's,${STAGEDIR}${PREFIX}/,, ; s,^,@dir ,' >> ${TMPPLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>