aboutsummaryrefslogtreecommitdiff
path: root/security/metasploit/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-11-24 09:49:34 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-11-24 09:49:34 +0000
commitcaad2e614ebeaa6ec7aa9a55302d1e559146b754 (patch)
tree552ca28e02939e6a85a9260c80cea6f094e569b6 /security/metasploit/Makefile
parent20b13072975c3acad0be65f1dcb476479c7bb726 (diff)
downloadports-caad2e614ebeaa6ec7aa9a55302d1e559146b754.tar.gz
ports-caad2e614ebeaa6ec7aa9a55302d1e559146b754.zip
Update to 4.17.26
Notes
Notes: svn path=/head/; revision=485746
Diffstat (limited to 'security/metasploit/Makefile')
-rw-r--r--security/metasploit/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/security/metasploit/Makefile b/security/metasploit/Makefile
index 320475c86d39..d40c2c7836a6 100644
--- a/security/metasploit/Makefile
+++ b/security/metasploit/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= metasploit
-PORTVERSION= 4.17.17
+PORTVERSION= 4.17.26
CATEGORIES= security
MAINTAINER= tanawts@gmail.com
@@ -28,7 +28,7 @@ RUN_DEPENDS= nmap:security/nmap \
rubygem-metasploit-credential>=0:security/rubygem-metasploit-credential \
rubygem-metasploit_data_models>=0:security/rubygem-metasploit_data_models \
rubygem-metasploit-model>=0:security/rubygem-metasploit-model \
- rubygem-metasploit-payloads>=1.3.52:security/rubygem-metasploit-payloads \
+ rubygem-metasploit-payloads>=1.3.53:security/rubygem-metasploit-payloads \
rubygem-metasploit_payloads-mettle>=0.4.2:security/rubygem-metasploit_payloads-mettle \
rubygem-msgpack1>=0:devel/rubygem-msgpack1 \
rubygem-network_interface>=0:net/rubygem-network_interface \
@@ -79,7 +79,8 @@ RUN_DEPENDS= nmap:security/nmap \
rubygem-nessus_rest>=0:security/rubygem-nessus_rest \
rubygem-nexpose>=0:security/rubygem-nexpose \
rubygem-xdr>=0:converters/rubygem-xdr \
- rubygem-faker>=0:devel/rubygem-faker
+ rubygem-faker>=0:devel/rubygem-faker \
+ rubygem-concurrent-ruby>=0:devel/rubygem-concurrent-ruby
SCRIPTS= msfconsole msfd msfrpc msfrpcd msfvenom
@@ -108,6 +109,7 @@ SHEBANG_FILES= data/exploits/CVE-2017-17562/build.sh \
docker/bin/msfconsole \
modules/auxiliary/dos/http/slowloris.py \
modules/auxiliary/dos/tcp/claymore_dos.py \
+ modules/auxiliary/gather/office365userenum.py \
modules/auxiliary/scanner/smb/impacket/dcomexec.py \
modules/auxiliary/scanner/smb/impacket/secretsdump.py \
modules/auxiliary/scanner/smb/impacket/wmiexec.py \
@@ -128,7 +130,8 @@ post-patch:
${REINPLACE_CMD} 's,git ls-files,find . ! -type d | sed "s|^./||", ; \
/rb-readline/d' \
${WRKSRC}/metasploit-framework.gemspec
- ${REINPLACE_CMD} "/pg/s|, '0.20.0'||" ${WRKSRC}/metasploit-framework.gemspec
+ ${REINPLACE_CMD} "/pg/s|, '0.20.0'||; \
+ /concurrent-ruby/s|,'1.0.5'||" ${WRKSRC}/metasploit-framework.gemspec
.if ${RUBY_VER} < 2.4
${REINPLACE_CMD} '/xmlrpc/d' ${WRKSRC}/metasploit-framework.gemspec
.endif