aboutsummaryrefslogtreecommitdiff
path: root/security/nettle/Makefile
diff options
context:
space:
mode:
authorJohan van Selst <johans@FreeBSD.org>2013-04-29 18:44:48 +0000
committerJohan van Selst <johans@FreeBSD.org>2013-04-29 18:44:48 +0000
commit12eca2a428b780bd976cf413c1b6989bff0062ea (patch)
tree3d559c0ff9b90b935c8b0cadd819de14ef2cd3c2 /security/nettle/Makefile
parentcf4d09185a9198c010ac22ecbc4b35e5b432dc99 (diff)
downloadports-12eca2a428b780bd976cf413c1b6989bff0062ea.tar.gz
ports-12eca2a428b780bd976cf413c1b6989bff0062ea.zip
Update Nettle to 2.7
Notes
Notes: svn path=/head/; revision=316836
Diffstat (limited to 'security/nettle/Makefile')
-rw-r--r--security/nettle/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/security/nettle/Makefile b/security/nettle/Makefile
index 801f04d008cc..b045af08fe4f 100644
--- a/security/nettle/Makefile
+++ b/security/nettle/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nettle
-PORTVERSION= 2.6
+PORTVERSION= 2.7
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNU} \
http://www.lysator.liu.se/~nisse/archive/:liu \
@@ -28,9 +28,8 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-DOCS= NEWS README TODO nettle.html nettle.pdf
-EXAMPLES= examples/*.c examples/*.h
-
+PORTDOCS= NEWS README TODO nettle.html nettle.pdf
+PORTEXAMPLES= *.c *.h
INFO= nettle
.include <bsd.port.pre.mk>
@@ -44,11 +43,11 @@ CONFIGURE_ENV+= CCPIC=-fPIC
post-install:
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${EXAMPLES} ${EXAMPLESDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} examples/${PORTEXAMPLES} ${EXAMPLESDIR}
.endif
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>