aboutsummaryrefslogtreecommitdiff
path: root/security/nmap/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2016-03-17 21:29:58 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2016-03-17 21:29:58 +0000
commit9b743fa397277216ac2d45214b45274862c89b4a (patch)
tree0111d5ed0e266006b86fabd899337195b070e74d /security/nmap/Makefile
parenta26289d7a7c8628fac33c4fb3710abdde7735d32 (diff)
downloadports-9b743fa397277216ac2d45214b45274862c89b4a.tar.gz
ports-9b743fa397277216ac2d45214b45274862c89b4a.zip
- upate to version 7.10
- remove support for custom IPv4 only kernel [1] Short summary: - 12 new NSE scripts - hundreds of new OS/version fingerprints - dozens if smaller improvements and bug fixes Full Changelog: https://nmap.org/changelog.html [1] nmap does no longer build agains custom kernel without IPv6!
Notes
Notes: svn path=/head/; revision=411320
Diffstat (limited to 'security/nmap/Makefile')
-rw-r--r--security/nmap/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/security/nmap/Makefile b/security/nmap/Makefile
index a1a0b45cc52d..978e95da4067 100644
--- a/security/nmap/Makefile
+++ b/security/nmap/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nmap
-DISTVERSION= 7.01
+DISTVERSION= 7.10
CATEGORIES= security ipv6
MASTER_SITES= http://nmap.org/dist/ \
LOCAL/ohauer
@@ -22,9 +22,10 @@ LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
USES= tar:bzip2 gmake cpe
GNU_CONFIGURE= yes
+# Note: nmap does no longer build agains custom kernel without IPv6!
OPTIONS_SUB= yes
-OPTIONS_DEFINE= DOCS IPV6 SSL
-OPTIONS_DEFAULT=IPV6 SSL
+OPTIONS_DEFINE= DOCS SSL
+OPTIONS_DEFAULT=SSL
SSL_USE= OPENSSL=yes
SSL_CONFIGURE_ON= --with-openssl=${OPENSSLBASE}
@@ -32,10 +33,6 @@ SSL_CONFIGURE_OFF= --without-openssl
SSL_CFLAGS= -I${OPENSSLINC}
SSL_VARS= STRIP_FILES=ncat
-# PR: ports/159376 Workaround if OS is build with WITHOUT_INET6
-IPV6_LIB_DEPENDS_OFF= libpcap.so:${PORTSDIR}/net/libpcap
-IPV6_CONFIGURE_OFF= --with-libpcap=${LOCALBASE}/IPv6
-
.include <bsd.port.options.mk>
DOCS= CHANGELOG HACKING