aboutsummaryrefslogtreecommitdiff
path: root/security/nss/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-12-28 06:17:39 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-12-28 06:17:39 +0000
commit2791e00a0c2f42d030e92c940be9529d802ad96f (patch)
treeed7ea33f3326bb8d01901db249db8e8ed7fa8b38 /security/nss/Makefile
parent2277ee24a4a30d14db4d21d9079935d2d75afd55 (diff)
downloadports-2791e00a0c2f42d030e92c940be9529d802ad96f.tar.gz
ports-2791e00a0c2f42d030e92c940be9529d802ad96f.zip
security/nss: expose TLS 1.3 support
This is going to be default in 3.29, recommended by upstream for 3.28 and will be required by Firefox >= 52.0.
Notes
Notes: svn path=/head/; revision=429713
Diffstat (limited to 'security/nss/Makefile')
-rw-r--r--security/nss/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/security/nss/Makefile b/security/nss/Makefile
index ab1f9a7126aa..8e84e31b8af3 100644
--- a/security/nss/Makefile
+++ b/security/nss/Makefile
@@ -4,6 +4,7 @@
PORTNAME= nss
PORTVERSION= 3.28
#DISTVERSIONSUFFIX= -with-ckbi-1.98
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= MOZILLA/security/${PORTNAME}/releases/${DISTNAME:tu:C/[-.]/_/g}_RTM/src
@@ -30,6 +31,7 @@ USE_PERL5= build
MAKE_ENV= LIBRARY_PATH="${LOCALBASE}/lib" \
SQLITE_INCLUDE_DIR="${LOCALBASE}/include" \
FREEBL_LOWHASH=1 \
+ NSS_ENABLE_TLS_1_3=1 \
NSS_DISABLE_GTESTS=1 \
NSS_USE_SYSTEM_SQLITE=1
CFLAGS+= -I${LOCALBASE}/include/nspr