aboutsummaryrefslogtreecommitdiff
path: root/security/nuclei/Makefile
diff options
context:
space:
mode:
authorGabriel M. Dutra <0xdutra@gmail.com>2022-10-25 12:42:46 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2022-10-25 12:42:46 +0000
commit2bceb891dc80c66b69d3a2a5a51ba8819bf04d2c (patch)
treee39ccb377ff79fbcc2924a395700ac68d984e05f /security/nuclei/Makefile
parent0155f0a274ec73652bf6c99737761ab23c0af165 (diff)
downloadports-2bceb891dc80c66b69d3a2a5a51ba8819bf04d2c.tar.gz
ports-2bceb891dc80c66b69d3a2a5a51ba8819bf04d2c.zip
Add security/nuclei: Fast vulnerability scanner
PR: 266509
Diffstat (limited to 'security/nuclei/Makefile')
-rw-r--r--security/nuclei/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/security/nuclei/Makefile b/security/nuclei/Makefile
new file mode 100644
index 000000000000..ed9b5c96cc04
--- /dev/null
+++ b/security/nuclei/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= nuclei
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.7.7
+CATEGORIES= security
+
+MAINTAINER= 0xdutra@gmail.com
+COMMENT= Fast vulnerability scanner
+WWW= https://github.com/projectdiscovery/nuclei
+
+LICENSE= MIT
+
+USES= go:modules
+GO_MODULE= github.com/projectdiscovery/nuclei/v2
+
+GO_TARGET= ./cmd/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>