aboutsummaryrefslogtreecommitdiff
path: root/security/obfsclient
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-10-08 18:06:49 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-10-08 18:06:49 +0000
commite4683c2c79890b5bd63ad894cbcb9b206863d237 (patch)
tree6325bf16d34d8a97e33fa0643e32298a2d0a54e4 /security/obfsclient
parent05e16fecabe85ef06b988830edb351949596e450 (diff)
downloadports-e4683c2c79890b5bd63ad894cbcb9b206863d237.tar.gz
ports-e4683c2c79890b5bd63ad894cbcb9b206863d237.zip
Mark BROKEN everywhere
c++ -DHAVE_CONFIG_H -I. -I./src -I. -isystem /usr/local/include -Wall -Werror -fno-exceptions -fno-rtti -D_THREAD_SAFE -pthread -I/usr/local/include -I/usr/local/include -I/usr/include -O2 -pipe -fstack-protector-strong -isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include -MT src/schwanenlied/crypto/obfsclient-base32.o -MD -MP -MF src/schwanenlied/crypto/.deps/obfsclient-base32.Tpo -c -o src/schwanenlied/crypto/obfsclient-base32.o `test -f 'src/schwanenlied/crypto/base32.cc' || echo './'`src/schwanenlied/crypto/base32.cc In file included from src/schwanenlied/crypto/base32.cc:34: In file included from ./src/schwanenlied/crypto/base32.h:37: In file included from ./src/schwanenlied/crypto/utils.h:40: In file included from ./src/schwanenlied/common.h:47: ./src/ext/easylogging++.h:1119:84: error: 'ptr_fun<int, int>' is deprecated [-Werror,-Wdeprecated-declarations] str.erase(str.begin(), std::find_if(str.begin(), str.end(), std::not1(std::ptr_fun<int, int>(&std::isspace)))); ^ /usr/include/c++/v1/functional:1107:1: note: 'ptr_fun<int, int>' has been explicitly marked deprecated here _LIBCPP_DEPRECATED_IN_CXX11 inline _LIBCPP_INLINE_VISIBILITY ^ /usr/include/c++/v1/__config:972:39: note: expanded from macro '_LIBCPP_DEPRECATED_IN_CXX11' # define _LIBCPP_DEPRECATED_IN_CXX11 _LIBCPP_DEPRECATED ^ /usr/include/c++/v1/__config:961:48: note: expanded from macro '_LIBCPP_DEPRECATED' # define _LIBCPP_DEPRECATED __attribute__ ((deprecated)) ^ In file included from src/schwanenlied/crypto/base32.cc:34: In file included from ./src/schwanenlied/crypto/base32.h:37: In file included from ./src/schwanenlied/crypto/utils.h:40: In file included from ./src/schwanenlied/common.h:47: ./src/ext/easylogging++.h:1126:73: error: 'ptr_fun<int, int>' is deprecated [-Werror,-Wdeprecated-declarations] str.erase(std::find_if(str.rbegin(), str.rend(), std::not1(std::ptr_fun<int, int>(&std::isspace))).base(), str.end()); ^ /usr/include/c++/v1/functional:1107:1: note: 'ptr_fun<int, int>' has been explicitly marked deprecated here _LIBCPP_DEPRECATED_IN_CXX11 inline _LIBCPP_INLINE_VISIBILITY ^ /usr/include/c++/v1/__config:972:39: note: expanded from macro '_LIBCPP_DEPRECATED_IN_CXX11' # define _LIBCPP_DEPRECATED_IN_CXX11 _LIBCPP_DEPRECATED ^ /usr/include/c++/v1/__config:961:48: note: expanded from macro '_LIBCPP_DEPRECATED' # define _LIBCPP_DEPRECATED __attribute__ ((deprecated)) ^ Reported by: pkg-fallout MFH: 2020Q4
Notes
Notes: svn path=/head/; revision=551728
Diffstat (limited to 'security/obfsclient')
-rw-r--r--security/obfsclient/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/security/obfsclient/Makefile b/security/obfsclient/Makefile
index 0e054c521dce..38f4caf4ca8d 100644
--- a/security/obfsclient/Makefile
+++ b/security/obfsclient/Makefile
@@ -32,6 +32,7 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.pre.mk>
+BROKEN= fails to build
.if ${SSL_DEFAULT} == base
BROKEN_FreeBSD_12= field has incomplete type 'HMAC_CTX' (aka 'hmac_ctx_st')
BROKEN_FreeBSD_13= field has incomplete type 'HMAC_CTX' (aka 'hmac_ctx_st')