aboutsummaryrefslogtreecommitdiff
path: root/security/opensaml/Makefile
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2018-08-07 13:24:36 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2018-08-07 13:24:36 +0000
commita42dc34f6bf6360ebe57fb96337888223daca55d (patch)
treea07a4ad5c3716e09d78110fdf20829c96f64a0dd /security/opensaml/Makefile
parent774faebe1ced0aaa447606361c3969ef47961ddc (diff)
downloadports-a42dc34f6bf6360ebe57fb96337888223daca55d.tar.gz
ports-a42dc34f6bf6360ebe57fb96337888223daca55d.zip
Update Shibboleth to 3.0.2
Also update the toolchain to latest versions. This includes a security fix for apache-xml-security-c. Releaseinfo: https://wiki.shibboleth.net/confluence/display/SP3/ReleaseNotes Security: 5786185a-9a43-11e8-b34b-6cc21735f730 Security: https://shibboleth.net/community/advisories/secadv_20180803.txt
Notes
Notes: svn path=/head/; revision=476595
Diffstat (limited to 'security/opensaml/Makefile')
-rw-r--r--security/opensaml/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/security/opensaml/Makefile b/security/opensaml/Makefile
new file mode 100644
index 000000000000..9a5317f0bda7
--- /dev/null
+++ b/security/opensaml/Makefile
@@ -0,0 +1,35 @@
+# Created by: Janos Mohacsi
+# $FreeBSD$
+
+PORTNAME= opensaml
+PORTVERSION= 3.0.0
+CATEGORIES= security
+MASTER_SITES= http://shibboleth.net/downloads/c++-opensaml/${PORTVERSION}/
+
+MAINTAINER= girgen@FreeBSD.org
+COMMENT= Open source implementation of SAML2
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= boost-libs>=0:devel/boost-libs
+LIB_DEPENDS= libcurl.so:ftp/curl \
+ liblog4shib.so:devel/log4shib \
+ libxml-security-c.so:security/apache-xml-security-c \
+ libxerces-c.so:textproc/xerces-c3 \
+ libxmltooling.so:devel/xmltooling
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--disable-doxygen-doc --disable-dependency-tracking
+USES= gmake libtool pkgconfig tar:bzip2 ssl
+USE_LDCONFIG= yes
+
+OPTIONS_DEFINE= DOCS
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^pkgdocdir.*=.*,pkgdocdir = ${DOCSDIR},' \
+ ${WRKSRC}/doc/Makefile.in
+
+post-patch-DOCS-off:
+ @${REINPLACE_CMD} -e '/^SUBDIRS/s,doc ,,' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>