aboutsummaryrefslogtreecommitdiff
path: root/security/openssh-askpass/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-09 13:31:29 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-09 13:31:29 +0000
commitced673a1bf33b86be29d3be7fae645f1287ecc42 (patch)
treeca43cb46823ff993ba129e015c1ceb5a9a627e10 /security/openssh-askpass/Makefile
parentfe9c26e1344b966308820e0dcc94a6c34b23c699 (diff)
downloadports-ced673a1bf33b86be29d3be7fae645f1287ecc42.tar.gz
ports-ced673a1bf33b86be29d3be7fae645f1287ecc42.zip
Support stage
Notes
Notes: svn path=/head/; revision=353463
Diffstat (limited to 'security/openssh-askpass/Makefile')
-rw-r--r--security/openssh-askpass/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/security/openssh-askpass/Makefile b/security/openssh-askpass/Makefile
index 5a5aaab34f0a..3b90fb190ded 100644
--- a/security/openssh-askpass/Makefile
+++ b/security/openssh-askpass/Makefile
@@ -14,28 +14,23 @@ COMMENT= Graphical password applet for entering SSH passphrase
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/README
+USES= uidfix
USE_XORG= x11 xt sm ice
DOCSDIR= ${PREFIX}/share/doc/ssh-askpass
PLIST_FILES= bin/x11-ssh-askpass \
bin/ssh-askpass \
- lib/X11/app-defaults/SshAskpass
+ lib/X11/app-defaults/SshAskpass \
+ man/man1/ssh-askpass.1.gz \
+ man/man1/x11-ssh-askpass.1.gz
PORTDOCS= README TODO ChangeLog
-MAN1= x11-ssh-askpass.1
-MLINKS= x11-ssh-askpass.1 ssh-askpass.1
-
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-extract:
${INSTALL_DATA} ${FILESDIR}/Makefile.in ${WRKSRC}/Makefile
-.if ${PORT_OPTIONS:MDOCS}
post-install:
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>